CVE-2021-32809 Arbitrary HTML injection vulnerability in ckeditor

Medium 4.6 Published Updated

Attackers can inject arbitrary HTML via malformed paste content in CKEditor 4, potentially leading to code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-32809?

CVE-2021-32809 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 12 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

Weakness: CWE-79, CWE-94

Which versions are affected by CVE-2021-32809?

2 open source packages ship an affected version, including ckeditor4. It affects 10 products.

PackageAffectedFixed in
ckeditor4 npmFrom 4.5.24.16.2
ckeditor4 npmFrom 4.5.24.16.2

Products include Ckeditor Ckeditor, Fedoraproject Fedora, Oracle Application Express, Oracle Banking Party Management, Oracle Commerce Guided Search, Oracle Commerce Merchandising and 4 more.

How do I fix CVE-2021-32809?

Upgrade ckeditor4 to 4.16.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-32809 being exploited?

There is no known exploitation of CVE-2021-32809 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as DEBIAN-CVE-2021-32809, GHSA-7889-rm5j-hpgg, UBUNTU-CVE-2021-32809.

Is CVE-2021-32809 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free