{"answers":{"affected":"2 open source packages ship an affected version, including ckeditor4. It affects 10 products.","exploited":"There is no known exploitation of CVE-2021-32809 in the wild and no public exploit code.","fix":"Upgrade ckeditor4 to 4.16.2 or later.","what":"CVE-2021-32809 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 12 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32809 and fix it if it is affected.\n\nWhat it is: CVE-2021-32809 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 12 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-32809 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ckeditor4 (npm): affected from 4.5.2; fixed in 4.16.2\n- ckeditor4 (npm): affected from 4.5.2; fixed in 4.16.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32809/ (Markdown: https://insights.sbomify.com/CVE-2021-32809/index.md)","id":"CVE-2021-32809","markdown":"https://insights.sbomify.com/CVE-2021-32809/index.md","name":"CVE-2021-32809","record":{"aliases":["DEBIAN-CVE-2021-32809","GHSA-7889-rm5j-hpgg","UBUNTU-CVE-2021-32809"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"CKEditor 4","requires_auth":"low_privilege","summary":"Attackers can inject arbitrary HTML via malformed paste content in CKEditor 4, potentially leading to code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ckeditor","vendor":"ckeditor"},{"product":"fedora","vendor":"fedoraproject"},{"product":"application_express","vendor":"oracle"},{"product":"banking_party_management","vendor":"oracle"},{"product":"commerce_guided_search","vendor":"oracle"},{"product":"commerce_merchandising","vendor":"oracle"},{"product":"documaker","vendor":"oracle"},{"product":"financial_services_analytical_applications_infrastructure","vendor":"oracle"},{"product":"jd_edwards_enterpriseone_tools","vendor":"oracle"},{"product":"peoplesoft_enterprise_peopletools","vendor":"oracle"}],"cvss":{"score":4.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version \u003e= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary HTML injection vulnerability in ckeditor","id":"CVE-2021-32809","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"fedoraproject:fedora","products":["fedoraproject:fedora","oracle:commerce_guided_search","oracle:financial_services_analytical_applications_infrastructure","oracle:jd_edwards_enterpriseone_tools","oracle:peoplesoft_enterprise_peopletools"],"type":"xss","year":"2021"},"n_packages":2,"n_references":6,"next":{"headline":"Data race in crossbeam-deque","id":"CVE-2021-32810"},"packages":[{"ecosystem":"npm","fixed":["4.16.2"],"introduced":["4.5.2"],"last_affected":[],"package":"ckeditor4","purl":null,"source":"GHSA-7889-rm5j-hpgg"},{"ecosystem":"npm","fixed":["4.16.2"],"introduced":["4.5.2"],"last_affected":[],"package":"ckeditor4","purl":"pkg:npm/ckeditor4","source":"GHSA-7889-rm5j-hpgg"}],"prev":{"headline":"Cross-site scripting in ckeditor via abuse of undo functionality","id":"CVE-2021-32808"},"products":["ckeditor4"],"published":"2021-08-12","related":[{"cvss_score":9.8,"headline":"File upload in n/a","id":"CVE-2023-31541","kev_date_added":null,"published":"2023-06-13"},{"cvss_score":8.2,"headline":"Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML","id":"CVE-2021-41164","kev_date_added":null,"published":"2021-11-17"},{"cvss_score":8.2,"headline":"HTML comments vulnerability allowing to execute JavaScript code","id":"CVE-2021-41165","kev_date_added":null,"published":"2021-11-17"},{"cvss_score":7.6,"headline":"Cross-site scripting in ckeditor via abuse of undo functionality","id":"CVE-2021-32808","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":7.5,"headline":"Missing authorization in CKEditor Drupal module","id":"CVE-2011-4972","kev_date_added":null,"published":"2019-11-13"},{"cvss_score":7.3,"headline":"Execution of JavaScript code using malformed HTML in ckeditor","id":"CVE-2021-37695","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":6.8,"headline":"Code injection in n/a","id":"CVE-2012-2067","kev_date_added":null,"published":"2012-09-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["ckeditor"]},"summary":"Attackers can inject arbitrary HTML via malformed paste content in CKEditor 4, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2021-32809/"}