# CVE-2021-32809: Arbitrary HTML injection vulnerability in ckeditor

> Attackers can inject arbitrary HTML via malformed paste content in CKEditor 4, potentially leading to code execution.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-32809, GHSA-7889-rm5j-hpgg, UBUNTU-CVE-2021-32809

## What is CVE-2021-32809?

CVE-2021-32809 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 12 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2021-32809?

2 open source packages ship an affected version, including ckeditor4. It affects 10 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckeditor4` | npm | From 4.5.2 | 4.16.2 |
| `ckeditor4` | npm | From 4.5.2 | 4.16.2 |

Products: Ckeditor Ckeditor, Fedoraproject Fedora, Oracle Application Express, Oracle Banking Party Management, Oracle Commerce Guided Search, Oracle Commerce Merchandising, Oracle Documaker, Oracle Financial Services Analytical Applications Infrastructure, Oracle Jd Edwards Enterpriseone Tools, Oracle Peoplesoft Enterprise Peopletools.

## How do I fix CVE-2021-32809?

Upgrade ckeditor4 to 4.16.2 or later.

## Is CVE-2021-32809 being exploited?

There is no known exploitation of CVE-2021-32809 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2023-31541](https://insights.sbomify.com/CVE-2023-31541/): File upload in n/a (critical 9.8)
- [CVE-2021-41164](https://insights.sbomify.com/CVE-2021-41164/): Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML (high 8.2)
- [CVE-2021-41165](https://insights.sbomify.com/CVE-2021-41165/): HTML comments vulnerability allowing to execute JavaScript code (high 8.2)
- [CVE-2021-32808](https://insights.sbomify.com/CVE-2021-32808/): Cross-site scripting in ckeditor via abuse of undo functionality (high 7.6)
- [CVE-2011-4972](https://insights.sbomify.com/CVE-2011-4972/): Missing authorization in CKEditor Drupal module (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32809 and fix it if it is affected.

What it is: CVE-2021-32809 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 12 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-32809 in the wild and no public exploit code.

Affected packages and fixed versions:
- ckeditor4 (npm): affected from 4.5.2; fixed in 4.16.2
- ckeditor4 (npm): affected from 4.5.2; fixed in 4.16.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32809/ (Markdown: https://insights.sbomify.com/CVE-2021-32809/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32809
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32809
- OSV: https://osv.dev/vulnerability/CVE-2021-32809

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32809/
Summaries are generated and may contain mistakes; the official description above is the record.
