CVE-2021-32810 Data race in crossbeam-deque
A race condition in crossbeam-deque allows tasks to be popped twice, potentially causing double frees and memory leaks in Rust applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-32810?
CVE-2021-32810 is a critical vulnerability in Fedoraproject Fedora, published on 2 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
crossbeam-deque is a package of work-stealing deques for building task schedulers when programming in Rust. In versions prior to 0.7.4 and 0.8.0, the result of the race condition is that one or more tasks in the worker queue can be popped twice instead of other tasks that are forgotten and never popped. If tasks are allocated on the heap, this can cause double free and a memory leak. If not, this still can cause a logical bug. Crates using `Stealer::steal`, `Stealer::steal_batch`, or `Stealer::steal_batch_and_pop` are affected by this issue. This has been fixed in crossbeam-deque 0.8.1 and 0.7.4.
Weakness: CWE-362
Which versions are affected by CVE-2021-32810?
5 open source packages ship an affected version, including crossbeam-deque. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
crossbeam-deque crates.io | All versions | 0.7.4 |
crossbeam-deque crates.io | All versions | 0.7.4 |
crossbeam-deque crates.io | From 0.0.0-0 | 0.7.4, 0.8.1 |
crossbeam-deque crates.io | From 0.8.0 | 0.8.1 |
crossbeam-deque crates.io | From 0.8.0 | 0.8.1 |
Products include Crossbeam Project Crossbeam, Fedoraproject Fedora.
How do I fix CVE-2021-32810?
Upgrade crossbeam-deque to a fixed version for your release line: 0.7.4 or 0.8.1.
Is CVE-2021-32810 being exploited?
There is no known exploitation of CVE-2021-32810 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as DEBIAN-CVE-2021-32810, GHSA-pqqp-xmhj-wgcw, RUSTSEC-2021-0093, UBUNTU-CVE-2021-32810.