# CVE-2021-32810: Data race in crossbeam-deque

> A race condition in crossbeam-deque allows tasks to be popped twice, potentially causing double frees and memory leaks in Rust applications.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-32810, GHSA-pqqp-xmhj-wgcw, RUSTSEC-2021-0093, UBUNTU-CVE-2021-32810

## What is CVE-2021-32810?

CVE-2021-32810 is a critical vulnerability in Fedoraproject Fedora, published on 2 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

crossbeam-deque is a package of work-stealing deques for building task schedulers when programming in Rust. In versions prior to 0.7.4 and 0.8.0, the result of the race condition is that one or more tasks in the worker queue can be popped twice instead of other tasks that are forgotten and never popped. If tasks are allocated on the heap, this can cause double free and a memory leak. If not, this still can cause a logical bug. Crates using `Stealer::steal`, `Stealer::steal_batch`, or `Stealer::steal_batch_and_pop` are affected by this issue. This has been fixed in crossbeam-deque 0.8.1 and 0.7.4.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2021-32810?

5 open source packages ship an affected version, including crossbeam-deque. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `crossbeam-deque` | crates.io | All versions | 0.7.4 |
| `crossbeam-deque` | crates.io | All versions | 0.7.4 |
| `crossbeam-deque` | crates.io | From 0.0.0-0 | 0.7.4, 0.8.1 |
| `crossbeam-deque` | crates.io | From 0.8.0 | 0.8.1 |
| `crossbeam-deque` | crates.io | From 0.8.0 | 0.8.1 |

Products: Crossbeam Project Crossbeam, Fedoraproject Fedora.

## How do I fix CVE-2021-32810?

Upgrade crossbeam-deque to a fixed version for your release line: 0.7.4 or 0.8.1.

## Is CVE-2021-32810 being exploited?

There is no known exploitation of CVE-2021-32810 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2018-20996](https://insights.sbomify.com/CVE-2018-20996/): Double free in crossbeam (critical 9.8)
- [CVE-2022-23639](https://insights.sbomify.com/CVE-2022-23639/): Improper Restriction of Operations within the Bounds of a Memory Buffer and Race Condition in crossbeam-utils (high 8.1)
- [CVE-2020-15254](https://insights.sbomify.com/CVE-2020-15254/): Undefined Behavior in bounded Crossbeam channel (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32810 and fix it if it is affected.

What it is: CVE-2021-32810 is a critical vulnerability in Fedoraproject Fedora, published on 2 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32810 in the wild and no public exploit code.

Affected packages and fixed versions:
- crossbeam-deque (crates.io): affected all versions; fixed in 0.7.4
- crossbeam-deque (crates.io): affected all versions; fixed in 0.7.4
- crossbeam-deque (crates.io): affected from 0.0.0-0; fixed in 0.7.4, 0.8.1
- crossbeam-deque (crates.io): affected from 0.8.0; fixed in 0.8.1
- crossbeam-deque (crates.io): affected from 0.8.0; fixed in 0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32810/ (Markdown: https://insights.sbomify.com/CVE-2021-32810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32810
- OSV: https://osv.dev/vulnerability/CVE-2021-32810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32810/
Summaries are generated and may contain mistakes; the official description above is the record.
