CVE-2021-32811 Remote Code Execution via Script (Python) objects under Python 3

High 7.5 Published Updated

Attackers with Manager role can execute arbitrary code via Script objects in Zope if untrusted users have web editing access.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-32811?

CVE-2021-32811 is a high-severity code injection vulnerability in zopefoundation Zope, published on 2 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope deployment, run Zope 4 below version 4.6.3 or Zope 5 below version 5.3, and have the optional `Products.PythonScripts` add-on package installed. By default, one must have the admin-level Zope "Manager" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web are at risk. Zope releases 4.6.3 and 5.3 are not vulnerable. As a workaround, a site administrator can restrict adding/editing Script (Python) objects through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing these scripts through the web should be restricted to trusted users only. This is the default configuration in Zope.

Weakness: CWE-1321, CWE-915

Which versions are affected by CVE-2021-32811?

6 open source packages ship an affected version, including zope, Zope and accesscontrol. It affects 2 products.

PackageAffectedFixed in
zope PyPIFrom 4.04.6.3, 5.3
zope PyPIFrom 4.04.6.3
zope PyPIFrom 5.05.3
Zope PyPIFrom 4.04.6.3
Zope PyPIFrom 5.05.3
accesscontrol PyPIFrom 4.04.3, 5.2

Products include Zope Accesscontrol, Zope Zope.

How do I fix CVE-2021-32811?

Upgrade zope to a fixed version for your release line: 4.6.3 or 5.3.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2021-32811 being exploited?

There is no known exploitation of CVE-2021-32811 in the wild and no public exploit code.

Sources

Also known as GHSA-g4gq-j4p2-j8fr, PYSEC-2021-368, PYSEC-2021-370, UBUNTU-CVE-2021-32811.

Is CVE-2021-32811 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free