# CVE-2021-32811: Remote Code Execution via Script (Python) objects under Python 3

> Attackers with Manager role can execute arbitrary code via Script objects in Zope if untrusted users have web editing access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-g4gq-j4p2-j8fr, PYSEC-2021-368, PYSEC-2021-370, UBUNTU-CVE-2021-32811

## What is CVE-2021-32811?

CVE-2021-32811 is a high-severity code injection vulnerability in zopefoundation Zope, published on 2 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope deployment, run Zope 4 below version 4.6.3 or Zope 5 below version 5.3, and have the optional `Products.PythonScripts` add-on package installed. By default, one must have the admin-level Zope "Manager" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web are at risk. Zope releases 4.6.3 and 5.3 are not vulnerable. As a workaround, a site administrator can restrict adding/editing Script (Python) objects through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing these scripts through the web should be restricted to trusted users only. This is the default configuration in Zope.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes), CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2021-32811?

6 open source packages ship an affected version, including zope, Zope and accesscontrol. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zope` | PyPI | From 4.0 | 4.6.3, 5.3 |
| `zope` | PyPI | From 4.0 | 4.6.3 |
| `zope` | PyPI | From 5.0 | 5.3 |
| `Zope` | PyPI | From 4.0 | 4.6.3 |
| `Zope` | PyPI | From 5.0 | 5.3 |
| `accesscontrol` | PyPI | From 4.0 | 4.3, 5.2 |

Products: Zope Accesscontrol, Zope Zope.

## How do I fix CVE-2021-32811?

Upgrade zope to a fixed version for your release line: 4.6.3 or 5.3.

## Is CVE-2021-32811 being exploited?

There is no known exploitation of CVE-2021-32811 in the wild and no public exploit code.

## Other vulnerabilities in zopefoundation Zope

- [CVE-2023-41050](https://insights.sbomify.com/CVE-2023-41050/): Information disclosure through Python's "format" functionality in Zope AccessControl (medium 6.8)
- [CVE-2021-32807](https://insights.sbomify.com/CVE-2021-32807/): Remote Code Execution via unsafe classes in otherwise permitted modules (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32811 and fix it if it is affected.

What it is: CVE-2021-32811 is a high-severity code injection vulnerability in zopefoundation Zope, published on 2 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32811 in the wild and no public exploit code.

Affected packages and fixed versions:
- zope (PyPI): affected from 4.0; fixed in 4.6.3, 5.3
- zope (PyPI): affected from 4.0; fixed in 4.6.3
- zope (PyPI): affected from 5.0; fixed in 5.3
- Zope (PyPI): affected from 4.0; fixed in 4.6.3
- Zope (PyPI): affected from 5.0; fixed in 5.3
- accesscontrol (PyPI): affected from 4.0; fixed in 4.3, 5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32811/ (Markdown: https://insights.sbomify.com/CVE-2021-32811/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32811
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32811
- OSV: https://osv.dev/vulnerability/CVE-2021-32811

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32811/
Summaries are generated and may contain mistakes; the official description above is the record.
