# CVE-2021-32817: File disclosure in express-hbs

> Attackers can read arbitrary files with extensions via the layout parameter in express-hbs, leading to information disclosure.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-handlebars-2021-32817, GHSA-rwxp-hwwf-653v

## What is CVE-2021-32817?

CVE-2021-32817 is a medium-severity path traversal vulnerability in TryGhost express-hbs, published on 14 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

express-hbs is an Express handlebars template engine. express-hbs mixes pure template data with engine configuration options through the Express render API. More specifically, the layout parameter may trigger file disclosure vulnerabilities in downstream applications. This potential vulnerability is somewhat restricted in that only files with existing extentions (i.e. file.extension) can be included, files that lack an extension will have .hbs appended to them. For complete details refer to the referenced GHSL-2021-019 report. Notes in documentation have been added to help users of express-hbs avoid this potential information exposure vulnerability.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-32817?

3 open source packages ship an affected version, including express-hbs and handlebars. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `express-hbs` | npm | All versions to 2.4.0 | None |
| `express-hbs` | npm | All versions to 2.4.0 | None |
| `handlebars` | Bitnami | All versions | 5.3.3 |

Products: Express Handlebars Project Express Handlebars.

## How do I fix CVE-2021-32817?

Apply the vendor's patch.

## Is CVE-2021-32817 being exploited?

There is no known exploitation of CVE-2021-32817 in the wild and no public exploit code.

## Other vulnerabilities in TryGhost express-hbs

- [CVE-2021-32820](https://insights.sbomify.com/CVE-2021-32820/): File disclosure in Express Handlebars (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32817 and fix it if it is affected.

What it is: CVE-2021-32817 is a medium-severity path traversal vulnerability in TryGhost express-hbs, published on 14 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32817 in the wild and no public exploit code.

Affected packages and fixed versions:
- express-hbs (npm): affected all versions up to 2.4.0; no fix listed
- express-hbs (npm): affected all versions up to 2.4.0; no fix listed
- handlebars (Bitnami): affected all versions; fixed in 5.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32817/ (Markdown: https://insights.sbomify.com/CVE-2021-32817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32817
- OSV: https://osv.dev/vulnerability/CVE-2021-32817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32817/
Summaries are generated and may contain mistakes; the official description above is the record.
