{"answers":{"affected":"2 open source packages ship an affected version, including squirrelly. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32819 exists.","fix":"Upgrade squirrelly to 9.0.0 or later.","what":"CVE-2021-32819 is a high-severity code injection vulnerability in squirrellyjs squirrelly, published on 14 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32819 and fix it if it is affected.\n\nWhat it is: CVE-2021-32819 is a high-severity code injection vulnerability in squirrellyjs squirrelly, published on 14 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32819 exists.\n\nAffected packages and fixed versions:\n- squirrelly (npm): affected all versions; fixed in 9.0.0\n- squirrelly (npm): affected all versions; fixed in 9.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32819/ (Markdown: https://insights.sbomify.com/CVE-2021-32819/index.md)","id":"CVE-2021-32819","markdown":"https://insights.sbomify.com/CVE-2021-32819/index.md","name":"CVE-2021-32819","record":{"aliases":["GHSA-q8j6-pwqx-pm96"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript template engine","requires_auth":"none","summary":"Attackers can achieve remote code execution in applications using Squirrelly by overwriting internal configuration options via the Express render API.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"squirrelly","vendor":"squirrelly"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Squirrelly is a template engine implemented in JavaScript that works out of the box with ExpressJS. Squirrelly mixes pure template data with engine configuration options through the Express render API. By overwriting internal configuration options remote code execution may be triggered in downstream applications. This issue is fixed in version 9.0.0. For complete details refer to the referenced GHSL-2021-023.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2021-06-12","github_poc":1,"max_poc_stars":10,"metasploit":0,"nuclei":1,"refs":[{"date":"2021-06-12T17:09:48Z","kind":"github_poc","ref":"https://github.com/Abady0x1/CVE-2021-32819","stars":10,"title":"SquirrellyJS mixes pure template data with engine configuration options through the Express render API. By overwriting internal configuration options, remote code execution may be triggered in downstream applications."},{"date":null,"kind":"nuclei","ref":"http/cves/2021/CVE-2021-32819.yaml","stars":null,"title":"Nodejs Squirrelly - Remote Code Execution"}],"tier":"weaponised"},"has_fix":true,"headline":"Remote code execution in squirrelly","id":"CVE-2021-32819","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"File disclosure in Express Handlebars","id":"CVE-2021-32820"},"packages":[{"ecosystem":"npm","fixed":["9.0.0"],"introduced":["0"],"last_affected":[],"package":"squirrelly","purl":null,"source":"GHSA-q8j6-pwqx-pm96"},{"ecosystem":"npm","fixed":["9.0.0"],"introduced":["0"],"last_affected":[],"package":"squirrelly","purl":"pkg:npm/squirrelly","source":"GHSA-q8j6-pwqx-pm96"}],"prev":{"headline":"Remote code execution and Reflected cross site scripting in haml-coffee","id":"CVE-2021-32818"},"products":["squirrelly"],"published":"2021-05-14","related":[{"cvss_score":9.8,"headline":"squirrelly Code Injection vulnerability","id":"CVE-2024-40453","kev_date_added":null,"published":"2024-08-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["squirrellyjs"]},"summary":"Attackers can achieve remote code execution in applications using Squirrelly by overwriting internal configuration options via the Express render API.","url":"https://insights.sbomify.com/CVE-2021-32819/"}