# CVE-2021-32819: Remote code execution in squirrelly

> Attackers can achieve remote code execution in applications using Squirrelly by overwriting internal configuration options via the Express render API.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-q8j6-pwqx-pm96

## What is CVE-2021-32819?

CVE-2021-32819 is a high-severity code injection vulnerability in squirrellyjs squirrelly, published on 14 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Squirrelly is a template engine implemented in JavaScript that works out of the box with ExpressJS. Squirrelly mixes pure template data with engine configuration options through the Express render API. By overwriting internal configuration options remote code execution may be triggered in downstream applications. This issue is fixed in version 9.0.0. For complete details refer to the referenced GHSL-2021-023.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-32819?

2 open source packages ship an affected version, including squirrelly. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `squirrelly` | npm | All versions | 9.0.0 |
| `squirrelly` | npm | All versions | 9.0.0 |

Products: Squirrelly Squirrelly.

## How do I fix CVE-2021-32819?

Upgrade squirrelly to 9.0.0 or later.

## Is CVE-2021-32819 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32819 exists.

Public exploit code:

- SquirrellyJS mixes pure template data with engine configuration options through the Express render API. By overwriting internal configuration options, remote code execution may be triggered in downstream applications. (github_poc): https://github.com/Abady0x1/CVE-2021-32819
- Nodejs Squirrelly - Remote Code Execution (nuclei): http/cves/2021/CVE-2021-32819.yaml

## Other vulnerabilities in squirrellyjs squirrelly

- [CVE-2024-40453](https://insights.sbomify.com/CVE-2024-40453/): squirrelly Code Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32819 and fix it if it is affected.

What it is: CVE-2021-32819 is a high-severity code injection vulnerability in squirrellyjs squirrelly, published on 14 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32819 exists.

Affected packages and fixed versions:
- squirrelly (npm): affected all versions; fixed in 9.0.0
- squirrelly (npm): affected all versions; fixed in 9.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32819/ (Markdown: https://insights.sbomify.com/CVE-2021-32819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32819
- OSV: https://osv.dev/vulnerability/CVE-2021-32819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32819/
Summaries are generated and may contain mistakes; the official description above is the record.
