# CVE-2021-32820: File disclosure in Express Handlebars

> Attackers can read arbitrary files with extensions via the layout parameter in Express Handlebars, leading to information disclosure.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-handlebars-2021-32820, GHSA-fr76-2wp8-fp92

## What is CVE-2021-32820?

CVE-2021-32820 is a high-severity path traversal vulnerability in express-handlebars, published on 14 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Express-handlebars is a Handlebars view engine for Express. Express-handlebars mixes pure template data with engine configuration options through the Express render API. More specifically, the layout parameter may trigger file disclosure vulnerabilities in downstream applications. This potential vulnerability is somewhat restricted in that only files with existing extentions (i.e. file.extension) can be included, files that lack an extension will have .handlebars appended to them. For complete details refer to the referenced GHSL-2021-018 report. Notes in documentation have been added to help users avoid this potential information exposure vulnerability.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-32820?

3 open source packages ship an affected version, including express-handlebars and handlebars. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `express-handlebars` | npm | All versions | 5.3.1 |
| `express-handlebars` | npm | All versions | 5.3.1 |
| `handlebars` | Bitnami | All versions | 5.3.3 |

Products: Express Handlebars Project Express Handlebars.

## How do I fix CVE-2021-32820?

Upgrade express-handlebars to 5.3.1 or later.

## Is CVE-2021-32820 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32820 exists.

Public exploit code:

- Express-handlebars - Local File Inclusion (nuclei): http/cves/2021/CVE-2021-32820.yaml

## Other vulnerabilities in express-handlebars

- [CVE-2021-32817](https://insights.sbomify.com/CVE-2021-32817/): File disclosure in express-hbs (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32820 and fix it if it is affected.

What it is: CVE-2021-32820 is a high-severity path traversal vulnerability in express-handlebars, published on 14 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32820 exists.

Affected packages and fixed versions:
- express-handlebars (npm): affected all versions; fixed in 5.3.1
- express-handlebars (npm): affected all versions; fixed in 5.3.1
- handlebars (Bitnami): affected all versions; fixed in 5.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32820/ (Markdown: https://insights.sbomify.com/CVE-2021-32820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32820
- OSV: https://osv.dev/vulnerability/CVE-2021-32820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32820/
Summaries are generated and may contain mistakes; the official description above is the record.
