CVE-2021-32823 Potential Denial-of-Service in bindata
An attacker can cause a CPU-based denial of service by triggering slow class creation in the bindata RubyGem library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-32823?
CVE-2021-32823 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 23 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In the bindata RubyGem before version 2.4.10 there is a potential denial-of-service vulnerability. In affected versions it is very slow for certain classes in BinData to be created. For example BinData::Bit100000, BinData::Bit100001, BinData::Bit100002, BinData::Bit<N>. In combination with <user_input>.constantize there is a potential for a CPU-based DoS. In version 2.4.10 bindata improved the creation time of Bits and Integers.
Weakness: CWE-400
Which versions are affected by CVE-2021-32823?
3 open source packages ship an affected version, including gitlab and bindata. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.0.0 | 13.10.5, 13.11.5, 13.12.2 |
bindata RubyGems | All versions | 2.4.10 |
bindata RubyGems | All versions | 2.4.10 |
Products include Bindata Project Bindata, Gitlab Gitlab.
How do I fix CVE-2021-32823?
Upgrade gitlab to a fixed version for your release line: 13.10.5, 13.11.5 or 13.12.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-32823 being exploited?
There is no known exploitation of CVE-2021-32823 in the wild and no public exploit code.
Sources
Also known as BIT-gitlab-2021-32823, DEBIAN-CVE-2021-32823, GHSA-hj56-84jw-67h6, UBUNTU-CVE-2021-32823.