# CVE-2021-32823: Potential Denial-of-Service in bindata

> An attacker can cause a CPU-based denial of service by triggering slow class creation in the bindata RubyGem library.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-gitlab-2021-32823, DEBIAN-CVE-2021-32823, GHSA-hj56-84jw-67h6, UBUNTU-CVE-2021-32823

## What is CVE-2021-32823?

CVE-2021-32823 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 23 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In the bindata RubyGem before version 2.4.10 there is a potential denial-of-service vulnerability. In affected versions it is very slow for certain classes in BinData to be created. For example BinData::Bit100000, BinData::Bit100001, BinData::Bit100002, BinData::Bit<N>. In combination with <user_input>.constantize there is a potential for a CPU-based DoS. In version 2.4.10 bindata improved the creation time of Bits and Integers.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-32823?

3 open source packages ship an affected version, including gitlab and bindata. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 12.0.0 | 13.10.5, 13.11.5, 13.12.2 |
| `bindata` | RubyGems | All versions | 2.4.10 |
| `bindata` | RubyGems | All versions | 2.4.10 |

Products: Bindata Project Bindata, Gitlab Gitlab.

## How do I fix CVE-2021-32823?

Upgrade gitlab to a fixed version for your release line: 13.10.5, 13.11.5 or 13.12.2.

## Is CVE-2021-32823 being exploited?

There is no known exploitation of CVE-2021-32823 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32823 and fix it if it is affected.

What it is: CVE-2021-32823 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 23 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32823 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 12.0.0; fixed in 13.10.5, 13.11.5, 13.12.2
- bindata (RubyGems): affected all versions; fixed in 2.4.10
- bindata (RubyGems): affected all versions; fixed in 2.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32823/ (Markdown: https://insights.sbomify.com/CVE-2021-32823/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32823
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32823
- OSV: https://osv.dev/vulnerability/CVE-2021-32823

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32823/
Summaries are generated and may contain mistakes; the official description above is the record.
