CVE-2021-32824 Regular expression Denial of Service in MooTools
Unauthenticated attackers can achieve remote code execution via unsafe deserialization in the Telnet handler of Apache Dubbo.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-32824?
CVE-2021-32824 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 3 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Dubbo is a java based, open source RPC framework. Versions prior to 2.6.10 and 2.7.10 are vulnerable to pre-auth remote code execution via arbitrary bean manipulation in the Telnet handler. The Dubbo main service port can be used to access a Telnet Handler which offers some basic methods to collect information about the providers and methods exposed by the service and it can even allow to shutdown the service. This endpoint is unprotected. Additionally, a provider method can be invoked using the `invoke` handler. This handler uses a safe version of FastJson to process the call arguments. However, the resulting list is later processed with `PojoUtils.realize` which can be used to instantiate arbitrary classes and invoke its setters. Even though FastJson is properly protected with a default blocklist, `PojoUtils.realize` is not, and an attacker can leverage that to achieve remote code execution. Versions 2.6.10 and 2.7.10 contain fixes for this issue.
Weakness: CWE-502
Which versions are affected by CVE-2021-32824?
4 open source packages ship an affected version, including org.apache.dubbo:dubbo-parent. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.dubbo:dubbo-parent Maven | All versions | 2.6.10 |
org.apache.dubbo:dubbo-parent Maven | All versions | 2.6.10 |
org.apache.dubbo:dubbo-parent Maven | From 2.7.0 | 2.7.10 |
org.apache.dubbo:dubbo-parent Maven | From 2.7.0 | 2.7.10 |
Products include Apache Dubbo.
How do I fix CVE-2021-32824?
Upgrade org.apache.dubbo:dubbo-parent to a fixed version for your release line: 2.6.10 or 2.7.10.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2021-32824 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32824 exists.
Other vulnerabilities in Apache Dubbo
- CVE-2023-29234 Bypass serialize checks in Apache Dubbo
- CVE-2023-46279 Apache Dubbo: Bypass deny serialize list check in Apache Dubbo
- CVE-2022-39198 Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass
- CVE-2021-43297 Dubbo Hessian cause RCE when parse error
- CVE-2021-36161 Unprotected input value toString cause RCE
Sources
Also known as GHSA-fprr-rrm8-4534.