# CVE-2021-32824: Regular expression Denial of Service in MooTools

> Unauthenticated attackers can achieve remote code execution via unsafe deserialization in the Telnet handler of Apache Dubbo.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-fprr-rrm8-4534

## What is CVE-2021-32824?

CVE-2021-32824 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 3 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Dubbo is a java based, open source RPC framework. Versions prior to 2.6.10 and 2.7.10 are vulnerable to pre-auth remote code execution via arbitrary bean manipulation in the Telnet handler. The Dubbo main service port can be used to access a Telnet Handler which offers some basic methods to collect information about the providers and methods exposed by the service and it can even allow to shutdown the service. This endpoint is unprotected. Additionally, a provider method can be invoked using the `invoke` handler. This handler uses a safe version of FastJson to process the call arguments. However, the resulting list is later processed with `PojoUtils.realize` which can be used to instantiate arbitrary classes and invoke its setters. Even though FastJson is properly protected with a default blocklist, `PojoUtils.realize` is not, and an attacker can leverage that to achieve remote code execution. Versions 2.6.10 and 2.7.10 contain fixes for this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-32824?

4 open source packages ship an affected version, including org.apache.dubbo:dubbo-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dubbo:dubbo-parent` | Maven | All versions | 2.6.10 |
| `org.apache.dubbo:dubbo-parent` | Maven | All versions | 2.6.10 |
| `org.apache.dubbo:dubbo-parent` | Maven | From 2.7.0 | 2.7.10 |
| `org.apache.dubbo:dubbo-parent` | Maven | From 2.7.0 | 2.7.10 |

Products: Apache Dubbo.

## How do I fix CVE-2021-32824?

Upgrade org.apache.dubbo:dubbo-parent to a fixed version for your release line: 2.6.10 or 2.7.10.

## Is CVE-2021-32824 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32824 exists.

## Other vulnerabilities in Apache Dubbo

- [CVE-2023-29234](https://insights.sbomify.com/CVE-2023-29234/): Bypass serialize checks in Apache Dubbo (critical 9.8)
- [CVE-2023-46279](https://insights.sbomify.com/CVE-2023-46279/): Apache Dubbo: Bypass deny serialize list check in Apache Dubbo (critical 9.8)
- [CVE-2022-39198](https://insights.sbomify.com/CVE-2022-39198/): Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass (critical 9.8)
- [CVE-2021-43297](https://insights.sbomify.com/CVE-2021-43297/): Dubbo Hessian cause RCE when parse error (critical 9.8)
- [CVE-2021-36161](https://insights.sbomify.com/CVE-2021-36161/): Unprotected input value toString cause RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32824 and fix it if it is affected.

What it is: CVE-2021-32824 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 3 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32824 exists.

Affected packages and fixed versions:
- org.apache.dubbo:dubbo-parent (Maven): affected all versions; fixed in 2.6.10
- org.apache.dubbo:dubbo-parent (Maven): affected all versions; fixed in 2.6.10
- org.apache.dubbo:dubbo-parent (Maven): affected from 2.7.0; fixed in 2.7.10
- org.apache.dubbo:dubbo-parent (Maven): affected from 2.7.0; fixed in 2.7.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32824/ (Markdown: https://insights.sbomify.com/CVE-2021-32824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32824
- OSV: https://osv.dev/vulnerability/CVE-2021-32824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32824/
Summaries are generated and may contain mistakes; the official description above is the record.
