# CVE-2021-32837: mechanize vulnerable to ReDoS

> A malicious web server can cause the mechanize library to crash via a regular expression denial of service attack.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jan 2023
- **Updated:** 22 Dec 2025
- **Also known as:** DEBIAN-CVE-2021-32837, DLA-3460-1, DLA-4418-1, GHSA-g3pv-pj5f-3hfq, MGASA-2023-0036, PYSEC-2023-25, UBUNTU-CVE-2021-32837, openSUSE-SU-2023:0030-1, openSUSE-SU-2024:12621-1, openSUSE-SU-2025:15098-1

## What is CVE-2021-32837?

CVE-2021-32837 is a high-severity denial of service vulnerability in python-mechanize mechanize, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mechanize, a library for automatically interacting with HTTP web servers, contains a regular expression that is vulnerable to regular expression denial of service (ReDoS) prior to version 0.4.6. If a web server responds in a malicious way, then mechanize could crash. Version 0.4.6 has a patch for the issue.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-32837?

3 open source packages ship an affected version, including mechanize. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mechanize` | PyPI | All versions | 0.4.6 |
| `mechanize` | PyPI | All versions | 0.4.6 |
| `mechanize` | PyPI | All versions | 0.4.6 |
| `python-mechanize` | SUSE:Package Hub 15 SP4 | All versions | 0.4.8-bp154.2.3.1 |
| `python-mechanize` | openSUSE:Leap 15.4 | All versions | 0.4.8-bp154.2.3.1 |
| `python-mechanize` | openSUSE:Tumbleweed | All versions | 0.4.10-1.4 |

Products: Mechanize Project Mechanize.

## How do I fix CVE-2021-32837?

Upgrade mechanize to 0.4.6 or later.

## Is CVE-2021-32837 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32837 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32837 and fix it if it is affected.

What it is: CVE-2021-32837 is a high-severity denial of service vulnerability in python-mechanize mechanize, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32837 exists.

Affected packages and fixed versions:
- mechanize (PyPI): affected all versions; fixed in 0.4.6
- mechanize (PyPI): affected all versions; fixed in 0.4.6
- mechanize (PyPI): affected all versions; fixed in 0.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32837/ (Markdown: https://insights.sbomify.com/CVE-2021-32837/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32837
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32837
- OSV: https://osv.dev/vulnerability/CVE-2021-32837

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32837/
Summaries are generated and may contain mistakes; the official description above is the record.
