# CVE-2021-32838: Regular Expression Denial of Service in flask-restx

> Attackers can cause denial of service in Flask-RESTX applications via inefficient email regex processing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Sep 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-3q6g-vf58-7m4g, MGASA-2021-0473, PYSEC-2021-325

## What is CVE-2021-32838?

CVE-2021-32838 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 20 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flask-RESTX (pypi package flask-restx) is a community driven fork of Flask-RESTPlus. Flask-RESTX before version 0.5.1 is vulnerable to ReDoS (Regular Expression Denial of Service) in email_regex. This is fixed in version 0.5.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-32838?

3 open source packages ship an affected version, including flask-restx. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-restx` | PyPI | All versions | 0.5.1 |
| `flask-restx` | PyPI | All versions | 0.5.1 |
| `flask-restx` | PyPI | All versions | 0.5.1 |

Products: Fedoraproject Fedora, Flask-Restx Project Flask-Restx.

## How do I fix CVE-2021-32838?

Upgrade flask-restx to 0.5.1 or later.

## Is CVE-2021-32838 being exploited?

There is no known exploitation of CVE-2021-32838 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32838 and fix it if it is affected.

What it is: CVE-2021-32838 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 20 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-32838 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-restx (PyPI): affected all versions; fixed in 0.5.1
- flask-restx (PyPI): affected all versions; fixed in 0.5.1
- flask-restx (PyPI): affected all versions; fixed in 0.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32838/ (Markdown: https://insights.sbomify.com/CVE-2021-32838/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32838
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32838
- OSV: https://osv.dev/vulnerability/CVE-2021-32838

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32838/
Summaries are generated and may contain mistakes; the official description above is the record.
