# CVE-2021-32849: Arbitrary command execution in Gerapy

> An authenticated user can execute arbitrary commands in the Gerapy distributed crawler management framework.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jan 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-756h-r2c9-qp5j, PYSEC-2022-17

## What is CVE-2021-32849?

CVE-2021-32849 is a high-severity command injection vulnerability in gerapy, published on 26 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gerapy is a distributed crawler management framework. Prior to version 0.9.9, an authenticated user could execute arbitrary commands. This issue is fixed in version 0.9.9. There are no known workarounds.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-32849?

3 open source packages ship an affected version, including gerapy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gerapy` | PyPI | All versions | 0.9.9 |
| `gerapy` | PyPI | All versions | 0.9.9 |
| `gerapy` | PyPI | All versions | 0.9.9 |

Products: Gerapy Gerapy.

## How do I fix CVE-2021-32849?

Upgrade gerapy to 0.9.9 or later.

## Is CVE-2021-32849 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32849 exists.

Public exploit code:

- cve-2021-32849(gerapy命令执行) (github_poc): https://github.com/lowkey0808/cve-2021-32849

## Other vulnerabilities in gerapy

- [CVE-2021-43857](https://insights.sbomify.com/CVE-2021-43857/): Gerapy may contain remote code execution vulnerability (critical 9.8)
- [CVE-2020-7698](https://insights.sbomify.com/CVE-2020-7698/): Command Injection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32849 and fix it if it is affected.

What it is: CVE-2021-32849 is a high-severity command injection vulnerability in gerapy, published on 26 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32849 exists.

Affected packages and fixed versions:
- gerapy (PyPI): affected all versions; fixed in 0.9.9
- gerapy (PyPI): affected all versions; fixed in 0.9.9
- gerapy (PyPI): affected all versions; fixed in 0.9.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32849/ (Markdown: https://insights.sbomify.com/CVE-2021-32849/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32849
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32849
- OSV: https://osv.dev/vulnerability/CVE-2021-32849

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32849/
Summaries are generated and may contain mistakes; the official description above is the record.
