{"answers":{"affected":"2 open source packages ship an affected version, including mind-elixir. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32851 exists.","fix":"Upgrade mind-elixir to 0.18.1 or later.","what":"CVE-2021-32851 is a medium-severity cross-site scripting vulnerability in npm mind-elixir, published on 20 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32851 and fix it if it is affected.\n\nWhat it is: CVE-2021-32851 is a medium-severity cross-site scripting vulnerability in npm mind-elixir, published on 20 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32851 exists.\n\nAffected packages and fixed versions:\n- mind-elixir (npm): affected all versions; fixed in 0.18.1\n- mind-elixir (npm): affected all versions; fixed in 0.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32851/ (Markdown: https://insights.sbomify.com/CVE-2021-32851/index.md)","id":"CVE-2021-32851","markdown":"https://insights.sbomify.com/CVE-2021-32851/index.md","name":"CVE-2021-32851","record":{"aliases":["GHSA-m22q-97p5-79v2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"mind-elixir library","requires_auth":"none","summary":"An attacker can execute arbitrary scripts via untrusted menus in the mind-elixir library, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mind-elixir","vendor":"mind-elixir_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Mind-elixir is a free, open source mind map core. Prior to version 0.18.1, mind-elixir is prone to cross-site scripting when handling untrusted menus. This issue is patched in version 0.18.1","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"jQuery MiniColors vulnerable to Cross-site Scripting","id":"CVE-2021-32851","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"countly-server vulnerable to Cross-site Scripting","id":"CVE-2021-32852"},"packages":[{"ecosystem":"npm","fixed":["0.18.1"],"introduced":["0"],"last_affected":[],"package":"mind-elixir","purl":null,"source":"GHSA-m22q-97p5-79v2"},{"ecosystem":"npm","fixed":["0.18.1"],"introduced":["0"],"last_affected":[],"package":"mind-elixir","purl":"pkg:npm/mind-elixir","source":"GHSA-m22q-97p5-79v2"}],"prev":{"headline":"jQuery MiniColors vulnerable to Cross-site Scripting","id":"CVE-2021-32850"},"products":["mind-elixir"],"published":"2023-02-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["npm"]},"summary":"An attacker can execute arbitrary scripts via untrusted menus in the mind-elixir library, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2021-32851/"}