{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32852 exists.","fix":"No fix has been published for CVE-2021-32852 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-32852 is a medium-severity cross-site scripting vulnerability in countly-server, published on 20 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32852 and fix it if it is affected.\n\nWhat it is: CVE-2021-32852 is a medium-severity cross-site scripting vulnerability in countly-server, published on 20 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32852 exists.\n\nAffected product: countly-server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32852/ (Markdown: https://insights.sbomify.com/CVE-2021-32852/index.md)","id":"CVE-2021-32852","markdown":"https://insights.sbomify.com/CVE-2021-32852/index.md","name":"CVE-2021-32852","record":{"aliases":["GHSA-7pfv-9vwr-6hpx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Countly analytics server","requires_auth":"low_privilege","summary":"An attacker with an account can execute scripts in victims' browsers via malicious links, potentially leading to session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"countly_server","vendor":"count"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Countly, a product analytics solution, is vulnerable to cross-site scripting prior to version 21.11 of the community edition. The victim must follow a malicious link or be redirected there from malicious web site. The attacker must have an account or be able to create one. This issue is patched in version 21.11.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"countly-server vulnerable to Cross-site Scripting","id":"CVE-2021-32852","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2021"},"n_packages":0,"n_references":4,"next":{"headline":"Erxes vulnerable to Cross-site Scripting","id":"CVE-2021-32853"},"packages":[],"prev":{"headline":"jQuery MiniColors vulnerable to Cross-site Scripting","id":"CVE-2021-32851"},"products":["countly-server"],"published":"2023-02-20","related":[{"cvss_score":8.1,"headline":"Predictable password reset token may lead to account takeover in countly-server","id":"CVE-2022-29174","kev_date_added":null,"published":"2022-05-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["Countly"]},"summary":"An attacker with an account can execute scripts in victims' browsers via malicious links, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2021-32852/"}