{"answers":{"affected":"2 open source packages ship an affected version, including vditor. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32855 exists.","fix":"Upgrade vditor to 3.8.7 or later.","what":"CVE-2021-32855 is a medium-severity cross-site scripting vulnerability in npm vditor, published on 20 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32855 and fix it if it is affected.\n\nWhat it is: CVE-2021-32855 is a medium-severity cross-site scripting vulnerability in npm vditor, published on 20 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32855 exists.\n\nAffected packages and fixed versions:\n- vditor (npm): affected all versions; fixed in 3.8.7\n- vditor (npm): affected all versions; fixed in 3.8.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32855/ (Markdown: https://insights.sbomify.com/CVE-2021-32855/index.md)","id":"CVE-2021-32855","markdown":"https://insights.sbomify.com/CVE-2021-32855/index.md","name":"CVE-2021-32855","record":{"aliases":["GHSA-vfmp-9999-6wqj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Markdown editor library","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in a victim's browser by tricking them into pasting malicious content into the Vditor Markdown editor.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vditor","vendor":"b3log"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Vditor is a browser-side Markdown editor. Versions prior to 3.8.7 are vulnerable to copy-paste cross-site scripting (XSS). For this particular type of XSS, the victim needs to be fooled into copying a malicious payload into the text editor. Version 3.8.7 contains a patch for this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vditor vulnerable to Cross-site Scripting","id":"CVE-2021-32855","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Microweber vulnerable to Cross-site Scripting","id":"CVE-2021-32856"},"packages":[{"ecosystem":"npm","fixed":["3.8.7"],"introduced":["0"],"last_affected":[],"package":"vditor","purl":null,"source":"GHSA-vfmp-9999-6wqj"},{"ecosystem":"npm","fixed":["3.8.7"],"introduced":["0"],"last_affected":[],"package":"vditor","purl":"pkg:npm/vditor","source":"GHSA-vfmp-9999-6wqj"}],"prev":{"headline":"textAngular text editor vulnerable to Cross-site Scripting","id":"CVE-2021-32854"},"products":["vditor"],"published":"2023-02-20","related":[{"cvss_score":6.8,"headline":"Cross-site Scripting (XSS) - Stored in vanessa219/vditor","id":"CVE-2021-4103","kev_date_added":null,"published":"2022-01-23"},{"cvss_score":6.6,"headline":"Cross-site Scripting (XSS) - Stored in vanessa219/vditor","id":"CVE-2022-0341","kev_date_added":null,"published":"2022-03-14"},{"cvss_score":6.1,"headline":"Vditor allows Cross-site Scripting via an attribute of an `A` element","id":"CVE-2024-34449","kev_date_added":null,"published":"2024-05-03"},{"cvss_score":6.1,"headline":"Cross-site Scripting (XSS) - Stored in vanessa219/vditor","id":"CVE-2022-0350","kev_date_added":null,"published":"2022-03-31"},{"cvss_score":5.9,"headline":"Path traversal in n/a","id":"CVE-2024-39150","kev_date_added":null,"published":"2024-07-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["npm"]},"summary":"An attacker can execute arbitrary scripts in a victim's browser by tricking them into pasting malicious content into the Vditor Markdown editor.","url":"https://insights.sbomify.com/CVE-2021-32855/"}