{"answers":{"affected":"2 open source packages ship an affected version, including izimodal. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32860 exists.","fix":"Upgrade izimodal to 1.6.1 or later.","what":"CVE-2021-32860 is a medium-severity cross-site scripting vulnerability in npm iziModal, published on 20 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-32860 and fix it if it is affected.\n\nWhat it is: CVE-2021-32860 is a medium-severity cross-site scripting vulnerability in npm iziModal, published on 20 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32860 exists.\n\nAffected packages and fixed versions:\n- izimodal (npm): affected all versions; fixed in 1.6.1\n- izimodal (npm): affected all versions; fixed in 1.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-32860/ (Markdown: https://insights.sbomify.com/CVE-2021-32860/index.md)","id":"CVE-2021-32860","markdown":"https://insights.sbomify.com/CVE-2021-32860/index.md","name":"CVE-2021-32860","record":{"aliases":["GHSA-h685-83w4-3ph3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"jQuery modal plugin","requires_auth":"none","summary":"An attacker can inject arbitrary HTML or JavaScript into iziModal titles, leading to cross-site scripting attacks against users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"izimodal","vendor":"izimodal_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"iziModal is a modal plugin with jQuery. Versions prior to 1.6.1 are vulnerable to cross-site scripting (XSS) when handling untrusted modal titles. An attacker who is able to influence the field `title` when creating a `iziModal` instance is able to supply arbitrary `html` or `javascript` code that will be rendered in the context of a user, potentially leading to `XSS`. Version 1.6.1 contains a patch for this issue","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"iziModal vulnerable to Cross-site Scripting","id":"CVE-2021-32860","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"nbconvert vulnerable to cross-site scripting (XSS) via multiple exploit paths","id":"CVE-2021-32862"},"packages":[{"ecosystem":"npm","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"izimodal","purl":null,"source":"GHSA-h685-83w4-3ph3"},{"ecosystem":"npm","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"izimodal","purl":"pkg:npm/izimodal","source":"GHSA-h685-83w4-3ph3"}],"prev":{"headline":"Baremetrics date range picker vulnerable to Cross-site Scripting","id":"CVE-2021-32859"},"products":["iziModal"],"published":"2023-02-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["npm"]},"summary":"An attacker can inject arbitrary HTML or JavaScript into iziModal titles, leading to cross-site scripting attacks against users.","url":"https://insights.sbomify.com/CVE-2021-32860/"}