# CVE-2021-32860: iziModal vulnerable to Cross-site Scripting

> An attacker can inject arbitrary HTML or JavaScript into iziModal titles, leading to cross-site scripting attacks against users.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-h685-83w4-3ph3

## What is CVE-2021-32860?

CVE-2021-32860 is a medium-severity cross-site scripting vulnerability in npm iziModal, published on 20 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

iziModal is a modal plugin with jQuery. Versions prior to 1.6.1 are vulnerable to cross-site scripting (XSS) when handling untrusted modal titles. An attacker who is able to influence the field `title` when creating a `iziModal` instance is able to supply arbitrary `html` or `javascript` code that will be rendered in the context of a user, potentially leading to `XSS`. Version 1.6.1 contains a patch for this issue

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-32860?

2 open source packages ship an affected version, including izimodal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `izimodal` | npm | All versions | 1.6.1 |
| `izimodal` | npm | All versions | 1.6.1 |

Products: Izimodal Project Izimodal.

## How do I fix CVE-2021-32860?

Upgrade izimodal to 1.6.1 or later.

## Is CVE-2021-32860 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32860 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-32860 and fix it if it is affected.

What it is: CVE-2021-32860 is a medium-severity cross-site scripting vulnerability in npm iziModal, published on 20 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-32860 exists.

Affected packages and fixed versions:
- izimodal (npm): affected all versions; fixed in 1.6.1
- izimodal (npm): affected all versions; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-32860/ (Markdown: https://insights.sbomify.com/CVE-2021-32860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-32860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-32860
- OSV: https://osv.dev/vulnerability/CVE-2021-32860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-32860/
Summaries are generated and may contain mistakes; the official description above is the record.
