{"answers":{"affected":"2 open source packages ship an affected version, including zencart/zencart. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-3291 exists.","fix":"Upgrade zencart/zencart to 1.5.7c or later.","what":"CVE-2021-3291 is a high-severity command injection vulnerability in n/a, published on 26 Jan 2021. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3291 and fix it if it is affected.\n\nWhat it is: CVE-2021-3291 is a high-severity command injection vulnerability in n/a, published on 26 Jan 2021. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-3291 exists.\n\nAffected packages and fixed versions:\n- zencart/zencart (Packagist): affected all versions; fixed in 1.5.7c\n- zencart/zencart (Packagist): affected all versions; fixed in 1.5.7c\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3291/ (Markdown: https://insights.sbomify.com/CVE-2021-3291/index.md)","id":"CVE-2021-3291","markdown":"https://insights.sbomify.com/CVE-2021-3291/index.md","name":"CVE-2021-3291","record":{"aliases":["GHSA-38f9-4vhq-9cr8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"E-commerce platform","requires_auth":"high_privilege","summary":"Administrators can execute arbitrary OS commands via HTML radio input manipulation in Zen Cart, requiring admin access.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"zen_cart","vendor":"zen-cart"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Zen Cart 1.5.7b allows admins to execute arbitrary OS commands by inspecting an HTML radio input element (within the modules edit page) and inserting a command.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2021-03-02","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2021-04-25T11:18:09Z","kind":"github_poc","ref":"https://github.com/ImHades101/CVE-2021-3291","stars":1,"title":"rebuild cve"},{"date":"2021-03-02","kind":"exploitdb","ref":"49608","stars":null,"title":"Zen Cart 1.5.7b - Remote Code Execution (Authenticated)"}],"tier":"weaponised"},"has_fix":true,"headline":"Zen Cart vulnerable to authenticated remote code execution","id":"CVE-2021-3291","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Information disclosure in n/a","id":"CVE-2021-3293"},"packages":[{"ecosystem":"Packagist","fixed":["1.5.7c"],"introduced":["0"],"last_affected":[],"package":"zencart/zencart","purl":null,"source":"GHSA-38f9-4vhq-9cr8"},{"ecosystem":"Packagist","fixed":["1.5.7c"],"introduced":["0"],"last_affected":[],"package":"zencart/zencart","purl":"pkg:composer/zencart/zencart","source":"GHSA-38f9-4vhq-9cr8"}],"prev":{"headline":"Deserialization in n/a","id":"CVE-2021-3287"},"products":["n/a"],"published":"2021-01-26","related":[{"cvss_score":10,"headline":"Missing authorization in n/a","id":"CVE-2006-0697","kev_date_added":null,"published":"2006-02-15"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2015-8352","kev_date_added":null,"published":"2017-08-24"},{"cvss_score":8.8,"headline":"Authenticated RCE in Zen Cart 1.5.5e","id":"CVE-2017-11675","kev_date_added":null,"published":"2017-07-27"},{"cvss_score":8.1,"headline":"Zen Cart findPluginAdminPage Local File Inclusion Remote Code Execution Vulnerability","id":"CVE-2024-5762","kev_date_added":null,"published":"2024-08-21"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2009-4323","kev_date_added":null,"published":"2009-12-14"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2009-2254","kev_date_added":null,"published":"2009-06-30"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2008-6615","kev_date_added":null,"published":"2009-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Administrators can execute arbitrary OS commands via HTML radio input manipulation in Zen Cart, requiring admin access.","url":"https://insights.sbomify.com/CVE-2021-3291/"}