CVE-2021-33036 Apache Hadoop Privilege escalation vulnerability

High 8.8 Published Updated

A user with yarn privileges can escalate to root and execute arbitrary commands in Apache Hadoop, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-33036?

CVE-2021-33036 is a high-severity vulnerability in Apache Hadoop, published on 15 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Weakness: CWE-22, CWE-264, CWE-24

Which versions are affected by CVE-2021-33036?

6 open source packages ship an affected version, including org.apache.hadoop:hadoop-yarn-server-common. It affects 1 product.

PackageAffectedFixed in
org.apache.hadoop:hadoop-yarn-server-common MavenFrom 2.2.02.10.2
org.apache.hadoop:hadoop-yarn-server-common MavenFrom 2.2.02.10.2
org.apache.hadoop:hadoop-yarn-server-common MavenFrom 3.0.03.2.3
org.apache.hadoop:hadoop-yarn-server-common MavenFrom 3.0.03.2.3
org.apache.hadoop:hadoop-yarn-server-common MavenFrom 3.3.03.3.2
org.apache.hadoop:hadoop-yarn-server-common MavenFrom 3.3.03.3.2

Products include Apache Hadoop.

How do I fix CVE-2021-33036?

Upgrade org.apache.hadoop:hadoop-yarn-server-common to a fixed version for your release line: 2.10.2, 3.2.3 or 3.3.2.

Is CVE-2021-33036 being exploited?

There is no known exploitation of CVE-2021-33036 in the wild and no public exploit code.

Sources

Also known as GHSA-58jx-f5rf-qgqf, OESA-2022-2016.

Is CVE-2021-33036 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free