# CVE-2021-33193: Request splitting via HTTP/2 method injection and mod_proxy

> Attackers can inject HTTP/2 methods to bypass validation and cause request splitting or cache poisoning in Apache HTTP Server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2021-33193, AZL-6483, BIT-apache-2021-33193, CLEANSTART-2026-XX88354, DEBIAN-CVE-2021-33193, GHSA-p9fg-6rr5-38xc, SUSE-SU-2021:2918-1, SUSE-SU-2021:2954-1, UBUNTU-CVE-2021-33193, openSUSE-SU-2021:1234-1, openSUSE-SU-2021:2954-1

## What is CVE-2021-33193?

CVE-2021-33193 is a high-severity vulnerability in Apache Http Server, published on 16 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A crafted method sent through HTTP/2 will bypass validation and be forwarded by mod_proxy, which can lead to request splitting or cache poisoning. This issue affects Apache HTTP Server 2.4.17 to 2.4.48.

## Which versions are affected by CVE-2021-33193?

1 open source package ship an affected version, including apache. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.17 | 2.4.49 |
| `apache2` | SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 2.4.43-3.25.1 |
| `apache2` | SUSE:Linux Enterprise Module for Basesystem 15 SP3 | All versions | 2.4.43-3.25.1 |
| `apache2` | SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 2.4.43-3.25.1 |
| `apache2` | SUSE:Linux Enterprise Module for Server Applications 15 SP2 | All versions | 2.4.43-3.25.1 |
| `apache2` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 2.4.43-3.25.1 |
| `apache2` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 2.4.23-29.77.2 |
| `apache2` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 2.4.23-29.77.2 |
| `apache2` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 2.4.23-29.77.2 |
| `apache2` | openSUSE:Leap 15.2 | All versions | 2.4.43-lp152.2.18.1 |
| `apache2` | openSUSE:Leap 15.3 | All versions | 2.4.43-3.25.1 |

Products: Apache Http Server, Debian Debian Linux, Fedoraproject Fedora, Oracle Secure Backup, Oracle Zfs Storage Appliance Kit, Tenable Tenable.sc.

## How do I fix CVE-2021-33193?

Upgrade apache to 2.4.49 or later.

## Is CVE-2021-33193 being exploited?

There is no known exploitation of CVE-2021-33193 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33193 and fix it if it is affected.

What it is: CVE-2021-33193 is a high-severity vulnerability in Apache Http Server, published on 16 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-33193 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.17; fixed in 2.4.49

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33193/ (Markdown: https://insights.sbomify.com/CVE-2021-33193/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33193
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33193
- OSV: https://osv.dev/vulnerability/CVE-2021-33193

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33193/
Summaries are generated and may contain mistakes; the official description above is the record.
