# CVE-2021-33295: Joplin Cross Site Scripting Vulnerability via NOSCRIPT tags

> Attackers can execute arbitrary code via XSS in Joplin Desktop App due to improper HTML sanitization.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-phj8-2p6x-hq5r

## What is CVE-2021-33295?

CVE-2021-33295 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting (XSS) vulnerability in Joplin Desktop App before 1.8.5 allows attackers to execute aribrary code due to improper sanitizing of html.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-33295?

2 open source packages ship an affected version, including joplin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joplin` | npm | All versions | 1.8.5 |
| `joplin` | npm | All versions | 1.8.5 |

Products: Joplin Project Joplin.

## How do I fix CVE-2021-33295?

Upgrade joplin to 1.8.5 or later.

## Is CVE-2021-33295 being exploited?

There is no known exploitation of CVE-2021-33295 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-23340](https://insights.sbomify.com/CVE-2022-23340/): Joplin Vulnerable to Code Injection (critical 9.8)
- [CVE-2024-40643](https://insights.sbomify.com/CVE-2024-40643/): Joplin has a parsing error leading to Cross-site Scripting (XSS) (critical 9.7)
- [CVE-2023-45673](https://insights.sbomify.com/CVE-2023-45673/): Arbitrary code execution on click of PDF links in Joplin (high 8.9)
- [CVE-2025-27134](https://insights.sbomify.com/CVE-2025-27134/): Privilege escalation in Joplin server via user patch endpoint (high 8.8)
- [CVE-2023-37898](https://insights.sbomify.com/CVE-2023-37898/): Safe mode Cross-site Scripting (XSS) vulnerability in Joplin (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33295 and fix it if it is affected.

What it is: CVE-2021-33295 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-33295 in the wild and no public exploit code.

Affected packages and fixed versions:
- joplin (npm): affected all versions; fixed in 1.8.5
- joplin (npm): affected all versions; fixed in 1.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33295/ (Markdown: https://insights.sbomify.com/CVE-2021-33295/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33295
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33295
- OSV: https://osv.dev/vulnerability/CVE-2021-33295

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33295/
Summaries are generated and may contain mistakes; the official description above is the record.
