# CVE-2021-33318: Improper Input Validation in IpMatcher

> Insufficient input validation in WatsonWebserver and IpMatcher allows bypassing IP-based access controls by manipulating IP address and netmask inputs.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-qj93-37f5-mr29

## What is CVE-2021-33318?

CVE-2021-33318 is a critical vulnerability in n/a, published on 16 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An Input Validation Vulnerability exists in Joel Christner .NET C# packages WatsonWebserver, IpMatcher 1.0.4.1 and below (IpMatcher) and 4.1.3 and below (WatsonWebserver) due to insufficient validation of input IP addresses and netmasks against the internal Matcher list of IP addresses and subnets.

Weakness: CWE-704 (Incorrect Type Conversion or Cast)

## Which versions are affected by CVE-2021-33318?

2 open source packages ship an affected version, including IpMatcher. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `IpMatcher` | NuGet | All versions | 1.0.4.2 |
| `IpMatcher` | NuGet | All versions | 1.0.4.2 |

Products: Ipmatcher Project Ipmatcher, Watsonwebserver Project Watsonwebserver.

## How do I fix CVE-2021-33318?

Upgrade IpMatcher to 1.0.4.2 or later.

## Is CVE-2021-33318 being exploited?

There is no known exploitation of CVE-2021-33318 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33318 and fix it if it is affected.

What it is: CVE-2021-33318 is a critical vulnerability in n/a, published on 16 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-33318 in the wild and no public exploit code.

Affected packages and fixed versions:
- IpMatcher (NuGet): affected all versions; fixed in 1.0.4.2
- IpMatcher (NuGet): affected all versions; fixed in 1.0.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33318/ (Markdown: https://insights.sbomify.com/CVE-2021-33318/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33318
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33318
- OSV: https://osv.dev/vulnerability/CVE-2021-33318

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33318/
Summaries are generated and may contain mistakes; the official description above is the record.
