# CVE-2021-33348: Cross-site scripting in jfinal

> Attackers can inject malicious scripts via the Controller set method in JFinal, potentially executing code in user browsers.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2c25-xfpq-8w9r

## What is CVE-2021-33348?

CVE-2021-33348 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in JFinal framework v4.9.10 and below. The "set" method of the "Controller" class of jfinal framework is not strictly filtered, which will lead to XSS vulnerabilities in some cases.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-33348?

2 open source packages ship an affected version, including com.jfinal:jfinal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.jfinal:jfinal` | Maven | All versions | 4.9.11 |
| `com.jfinal:jfinal` | Maven | All versions | 4.9.11 |

Products: Jfinal Jfinal.

## How do I fix CVE-2021-33348?

Upgrade com.jfinal:jfinal to 4.9.11 or later.

## Is CVE-2021-33348 being exploited?

There is no known exploitation of CVE-2021-33348 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-31635](https://insights.sbomify.com/CVE-2021-31635/): jFinal Server-Side Template Injection vulnerability (critical 9.8)
- [CVE-2021-31649](https://insights.sbomify.com/CVE-2021-31649/): JFinal Java Deserialization Vulnerability (critical 9.8)
- [CVE-2019-17352](https://insights.sbomify.com/CVE-2019-17352/): JFinal file validation vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33348 and fix it if it is affected.

What it is: CVE-2021-33348 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-33348 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.jfinal:jfinal (Maven): affected all versions; fixed in 4.9.11
- com.jfinal:jfinal (Maven): affected all versions; fixed in 4.9.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33348/ (Markdown: https://insights.sbomify.com/CVE-2021-33348/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33348
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33348
- OSV: https://osv.dev/vulnerability/CVE-2021-33348

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33348/
Summaries are generated and may contain mistakes; the official description above is the record.
