# CVE-2021-33473: Arbitrary file write in dragonfly

> Attackers can read and write arbitrary files via crafted URLs if the verify_url option is disabled in the Dragonfly Ruby Gem.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-fj34-jhjx-xmvv

## What is CVE-2021-33473?

CVE-2021-33473 is a critical path traversal vulnerability in n/a, published on 2 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An argument injection vulnerability in Dragonfly Ruby Gem v1.3.0 allows attackers to read and write arbitrary files when the verify_url option is disabled. This vulnerability is exploited via a crafted URL.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2021-33473?

2 open source packages ship an affected version, including dragonfly. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dragonfly` | RubyGems | All versions | 1.4.0 |
| `dragonfly` | RubyGems | All versions | 1.4.0 |

Products: Dragonfly Project Dragonfly.

## How do I fix CVE-2021-33473?

Upgrade dragonfly to 1.4.0 or later.

## Is CVE-2021-33473 being exploited?

There is no known exploitation of CVE-2021-33473 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-33564](https://insights.sbomify.com/CVE-2021-33564/): Dragonfly contains remote code execution vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33473 and fix it if it is affected.

What it is: CVE-2021-33473 is a critical path traversal vulnerability in n/a, published on 2 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-33473 in the wild and no public exploit code.

Affected packages and fixed versions:
- dragonfly (RubyGems): affected all versions; fixed in 1.4.0
- dragonfly (RubyGems): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33473/ (Markdown: https://insights.sbomify.com/CVE-2021-33473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33473
- OSV: https://osv.dev/vulnerability/CVE-2021-33473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33473/
Summaries are generated and may contain mistakes; the official description above is the record.
