# CVE-2021-33496: Cross-site scripting in Dutchcoders transfer.sh

> An attacker can execute arbitrary scripts in the victim's browser via an inline view in the transfer.sh file sharing service.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-w3jx-wv97-67ph, GO-2022-0924

## What is CVE-2021-33496?

CVE-2021-33496 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Dutchcoders transfer.sh before 1.2.4 allows XSS via an inline view.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-33496?

3 open source packages ship an affected version, including github.com/dutchcoders/transfer.sh. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/dutchcoders/transfer.sh` | Go | All versions | 1.2.4 |
| `github.com/dutchcoders/transfer.sh` | Go | All versions | 1.2.4 |
| `github.com/dutchcoders/transfer.sh` | Go | All versions | 1.2.4 |

Products: Dutchcoders Transfer.sh.

## How do I fix CVE-2021-33496?

Upgrade github.com/dutchcoders/transfer.sh to 1.2.4 or later.

## Is CVE-2021-33496 being exploited?

There is no known exploitation of CVE-2021-33496 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-33497](https://insights.sbomify.com/CVE-2021-33497/): Path Traversal in Dutchcoders transfer.sh (critical 9.1)
- [CVE-2022-40931](https://insights.sbomify.com/CVE-2022-40931/): Dutchoders transfer.sh contains an XSS vulnerability via malicious file upload (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33496 and fix it if it is affected.

What it is: CVE-2021-33496 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-33496 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/dutchcoders/transfer.sh (Go): affected all versions; fixed in 1.2.4
- github.com/dutchcoders/transfer.sh (Go): affected all versions; fixed in 1.2.4
- github.com/dutchcoders/transfer.sh (Go): affected all versions; fixed in 1.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33496/ (Markdown: https://insights.sbomify.com/CVE-2021-33496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33496
- OSV: https://osv.dev/vulnerability/CVE-2021-33496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33496/
Summaries are generated and may contain mistakes; the official description above is the record.
