# CVE-2021-33507: Cross-site scripting in Products.CMFCore, Products.PluggableAuthService, Plone

> Reflected XSS in Zope Products.CMFCore and PluggableAuthService allows attackers to execute arbitrary scripts in user browsers.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-35rg-466w-77h3, PYSEC-2021-79, PYSEC-2026-2961, PYSEC-2026-2967

## What is CVE-2021-33507?

CVE-2021-33507 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 21 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Zope Products.CMFCore before 2.5.1 and Products.PluggableAuthService before 2.6.2, as used in Plone through 5.2.4 and other products, allow Reflected XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-33507?

9 open source packages ship an affected version, including plone, Plone and Products.CMFCore. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | All versions to 5.2.4 | None |
| `plone` | PyPI | All versions | 5.2.5 |
| `Plone` | PyPI | All versions to 5.2.4 | None |
| `Products.CMFCore` | PyPI | All versions | 2.5.1 |
| `Products.PluggableAuthService` | PyPI | All versions | 2.6.2 |
| `products-cmfcore` | PyPI | All versions | 2.5.1 |
| `products-cmfcore` | PyPI | All versions | 2.5.1 |
| `products-pluggableauthservice` | PyPI | All versions | 2.6.2 |
| `products-pluggableauthservice` | PyPI | All versions | 2.6.2 |

Products: Plone Plone, Zope Zope.

## How do I fix CVE-2021-33507?

Upgrade plone to 5.2.5 or later.

## Is CVE-2021-33507 being exploited?

There is no known exploitation of CVE-2021-33507 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33507 and fix it if it is affected.

What it is: CVE-2021-33507 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 21 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-33507 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected all versions up to 5.2.4; no fix listed
- plone (PyPI): affected all versions; fixed in 5.2.5
- Plone (PyPI): affected all versions up to 5.2.4; no fix listed
- Products.CMFCore (PyPI): affected all versions; fixed in 2.5.1
- Products.PluggableAuthService (PyPI): affected all versions; fixed in 2.6.2
- products-cmfcore (PyPI): affected all versions; fixed in 2.5.1
- products-cmfcore (PyPI): affected all versions; fixed in 2.5.1
- products-pluggableauthservice (PyPI): affected all versions; fixed in 2.6.2
- products-pluggableauthservice (PyPI): affected all versions; fixed in 2.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33507/ (Markdown: https://insights.sbomify.com/CVE-2021-33507/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33507
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33507
- OSV: https://osv.dev/vulnerability/CVE-2021-33507

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33507/
Summaries are generated and may contain mistakes; the official description above is the record.
