# CVE-2021-33561: Cross-site scripting in Shopizer

> Remote attackers can inject arbitrary scripts via customer names in Shopizer, leading to code execution or account takeover for store administrators.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rcp4-jm2v-mr3f

## What is CVE-2021-33561?

CVE-2021-33561 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 May 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A stored cross-site scripting (XSS) vulnerability in Shopizer before 2.17.0 allows remote attackers to inject arbitrary web script or HTML via customer_name in various forms of store administration. It is saved in the database. The code is executed for any user of store administration when information is fetched from the backend, e.g., in admin/customers/list.html.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-33561?

2 open source packages ship an affected version, including com.shopizer:shopizer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.shopizer:shopizer` | Maven | All versions | 2.17.0 |
| `com.shopizer:shopizer` | Maven | All versions | 2.17.0 |

Products: Shopizer Shopizer.

## How do I fix CVE-2021-33561?

Upgrade com.shopizer:shopizer to 2.17.0 or later.

## Is CVE-2021-33561 being exploited?

There is no known exploitation of CVE-2021-33561 in the wild and no public exploit code.

Public exploit code:

- Shopizer 2.16.0 - 'Multiple' Cross-Site Scripting (XSS) (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2020-11006](https://insights.sbomify.com/CVE-2020-11006/): Potential remote code execution in Shopizer (critical 9.1)
- [CVE-2022-23063](https://insights.sbomify.com/CVE-2022-23063/): Shopizer - Insufficient Session Expiration (high 8.8)
- [CVE-2025-51605](https://insights.sbomify.com/CVE-2025-51605/): Security feature bypass in n/a (high 8.1)
- [CVE-2014-4963](https://insights.sbomify.com/CVE-2014-4963/): Missing authorization in n/a (medium 6.8)
- [CVE-2014-4964](https://insights.sbomify.com/CVE-2014-4964/): Cross-site request forgery in n/a (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33561 and fix it if it is affected.

What it is: CVE-2021-33561 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 May 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-33561 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.shopizer:shopizer (Maven): affected all versions; fixed in 2.17.0
- com.shopizer:shopizer (Maven): affected all versions; fixed in 2.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33561/ (Markdown: https://insights.sbomify.com/CVE-2021-33561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33561
- OSV: https://osv.dev/vulnerability/CVE-2021-33561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33561/
Summaries are generated and may contain mistakes; the official description above is the record.
