{"answers":{"affected":"2 open source packages ship an affected version, including dragonfly. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-33564 exists.","fix":"Upgrade dragonfly to 1.4.0 or later.","what":"CVE-2021-33564 is a critical command injection vulnerability in n/a, published on 29 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-33564 and fix it if it is affected.\n\nWhat it is: CVE-2021-33564 is a critical command injection vulnerability in n/a, published on 29 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-33564 exists.\n\nAffected packages and fixed versions:\n- dragonfly (RubyGems): affected all versions; fixed in 1.4.0\n- dragonfly (RubyGems): affected all versions; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-33564/ (Markdown: https://insights.sbomify.com/CVE-2021-33564/index.md)","id":"CVE-2021-33564","markdown":"https://insights.sbomify.com/CVE-2021-33564/index.md","name":"CVE-2021-33564","record":{"aliases":["GHSA-j858-xp5v-f8xx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby Dragonfly gem","requires_auth":"none","summary":"Remote attackers can execute arbitrary code or read/write files via argument injection in the Dragonfly gem when URL verification is disabled.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dragonfly","vendor":"dragonfly_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verify_url option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":"2021-05-25","github_poc":2,"max_poc_stars":16,"metasploit":0,"nuclei":1,"refs":[{"date":"2021-05-25T02:48:08Z","kind":"github_poc","ref":"https://github.com/mlr0p/CVE-2021-33564","stars":16,"title":"Argument Injection in Dragonfly Ruby Gem"},{"date":"2021-05-27T15:44:45Z","kind":"github_poc","ref":"https://github.com/dorkerdevil/CVE-2021-33564","stars":0,"title":"Argument Injection in Dragonfly Ruby Gem exploit (backup)"},{"date":null,"kind":"nuclei","ref":"http/cves/2021/CVE-2021-33564.yaml","stars":null,"title":"Ruby Dragonfly \u003c1.4.0 - Remote Code Execution"}],"tier":"weaponised"},"has_fix":true,"headline":"Dragonfly contains remote code execution vulnerability","id":"CVE-2021-33564","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2021"},"n_packages":2,"n_references":6,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-33570"},"packages":[{"ecosystem":"RubyGems","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"dragonfly","purl":null,"source":"GHSA-j858-xp5v-f8xx"},{"ecosystem":"RubyGems","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"dragonfly","purl":"pkg:gem/dragonfly","source":"GHSA-j858-xp5v-f8xx"}],"prev":{"headline":"Improper rate limiting in Koel","id":"CVE-2021-33563"},"products":["n/a"],"published":"2021-05-29","related":[{"cvss_score":9.1,"headline":"Arbitrary file write in dragonfly","id":"CVE-2021-33473","kev_date_added":null,"published":"2022-06-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code or read/write files via argument injection in the Dragonfly gem when URL verification is disabled.","url":"https://insights.sbomify.com/CVE-2021-33564/"}