# CVE-2021-33564: Dragonfly contains remote code execution vulnerability

> Remote attackers can execute arbitrary code or read/write files via argument injection in the Dragonfly gem when URL verification is disabled.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-j858-xp5v-f8xx

## What is CVE-2021-33564?

CVE-2021-33564 is a critical command injection vulnerability in n/a, published on 29 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verify_url option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2021-33564?

2 open source packages ship an affected version, including dragonfly. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dragonfly` | RubyGems | All versions | 1.4.0 |
| `dragonfly` | RubyGems | All versions | 1.4.0 |

Products: Dragonfly Project Dragonfly.

## How do I fix CVE-2021-33564?

Upgrade dragonfly to 1.4.0 or later.

## Is CVE-2021-33564 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-33564 exists.

Public exploit code:

- Argument Injection in Dragonfly Ruby Gem (github_poc): https://github.com/mlr0p/CVE-2021-33564
- Argument Injection in Dragonfly Ruby Gem exploit (backup) (github_poc): https://github.com/dorkerdevil/CVE-2021-33564
- Ruby Dragonfly <1.4.0 - Remote Code Execution (nuclei): http/cves/2021/CVE-2021-33564.yaml

## Other vulnerabilities in n/a

- [CVE-2021-33473](https://insights.sbomify.com/CVE-2021-33473/): Arbitrary file write in dragonfly (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33564 and fix it if it is affected.

What it is: CVE-2021-33564 is a critical command injection vulnerability in n/a, published on 29 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-33564 exists.

Affected packages and fixed versions:
- dragonfly (RubyGems): affected all versions; fixed in 1.4.0
- dragonfly (RubyGems): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33564/ (Markdown: https://insights.sbomify.com/CVE-2021-33564/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33564
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33564
- OSV: https://osv.dev/vulnerability/CVE-2021-33564

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33564/
Summaries are generated and may contain mistakes; the official description above is the record.
