# CVE-2021-33571: Django Access Control Bypass possibly leading to SSRF, RFI, and LFI attacks

> Attackers can bypass IP-based access controls in Django applications by using octal literals in IP addresses, potentially gaining unauthorized access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-django-2021-33571, DEBIAN-CVE-2021-33571, GHSA-p99v-5w3c-jqq9, PYSEC-2021-99, UBUNTU-CVE-2021-33571

## What is CVE-2021-33571?

CVE-2021-33571 is a high-severity vulnerability in Djangoproject Django, published on 8 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Django 2.2 before 2.2.24, 3.x before 3.1.12, and 3.2 before 3.2.4, URLValidator, validate_ipv4_address, and validate_ipv46_address do not prohibit leading zero characters in octal literals. This may allow a bypass of access control that is based on IP addresses. (validate_ipv4_address and validate_ipv46_address are unaffected with Python 3.9.5+..) .

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2021-33571?

8 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 2.2.0 | 2.2.24, 3.1.12, 3.2.4 |
| `django` | PyPI | From 2.2 | 2.2.24, 3.1.12, 3.2.4 |
| `django` | PyPI | From 2.2a1 | 2.2.24 |
| `django` | PyPI | From 3.0a1 | 3.1.12 |
| `django` | PyPI | From 3.2a1 | 3.2.4 |
| `Django` | PyPI | From 2.2a1 | 2.2.24 |
| `Django` | PyPI | From 3.0a1 | 3.1.12 |
| `Django` | PyPI | From 3.2a1 | 3.2.4 |

Products: Djangoproject Django, Fedoraproject Fedora.

## How do I fix CVE-2021-33571?

Upgrade django to a fixed version for your release line: 2.2.24, 3.1.12 or 3.2.4.

## Is CVE-2021-33571 being exploited?

There is no known exploitation of CVE-2021-33571 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33571 and fix it if it is affected.

What it is: CVE-2021-33571 is a high-severity vulnerability in Djangoproject Django, published on 8 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-33571 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 2.2.0; fixed in 2.2.24, 3.1.12, 3.2.4
- django (PyPI): affected from 2.2; fixed in 2.2.24, 3.1.12, 3.2.4
- django (PyPI): affected from 2.2a1; fixed in 2.2.24
- django (PyPI): affected from 3.0a1; fixed in 3.1.12
- django (PyPI): affected from 3.2a1; fixed in 3.2.4
- Django (PyPI): affected from 2.2a1; fixed in 2.2.24
- Django (PyPI): affected from 3.0a1; fixed in 3.1.12
- Django (PyPI): affected from 3.2a1; fixed in 3.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33571/ (Markdown: https://insights.sbomify.com/CVE-2021-33571/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33571
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33571
- OSV: https://osv.dev/vulnerability/CVE-2021-33571

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33571/
Summaries are generated and may contain mistakes; the official description above is the record.
