{"answers":{"affected":"2 open source packages ship an affected version, including ruby-jss. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-33575 in the wild and no public exploit code.","fix":"Upgrade ruby-jss to 1.6.0 or later.","what":"CVE-2021-33575 is a critical vulnerability in n/a, published on 25 May 2021."},"fix_prompt":"Check this codebase for CVE-2021-33575 and fix it if it is affected.\n\nWhat it is: CVE-2021-33575 is a critical vulnerability in n/a, published on 25 May 2021. \nExploitation: There is no known exploitation of CVE-2021-33575 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ruby-jss (RubyGems): affected all versions; fixed in 1.6.0\n- ruby-jss (RubyGems): affected all versions; fixed in 1.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-33575/ (Markdown: https://insights.sbomify.com/CVE-2021-33575/index.md)","id":"CVE-2021-33575","markdown":"https://insights.sbomify.com/CVE-2021-33575/index.md","name":"CVE-2021-33575","record":{"aliases":["GHSA-vmfh-c547-v45h"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"ruby-jss","vendor":"pixar"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"The Pixar ruby-jss gem before 1.6.0 allows remote attackers to execute arbitrary code because of the Plist gem's documented behavior of using Marshal.load during XML document processing.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote code execution in ruby-jss","id":"CVE-2021-33575","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":null,"year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Path traversal in n/a","id":"CVE-2021-33576"},"packages":[{"ecosystem":"RubyGems","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"ruby-jss","purl":null,"source":"GHSA-vmfh-c547-v45h"},{"ecosystem":"RubyGems","fixed":["1.6.0"],"introduced":["0"],"last_affected":[],"package":"ruby-jss","purl":"pkg:gem/ruby-jss","source":"GHSA-vmfh-c547-v45h"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2021-33574"},"products":["n/a"],"published":"2021-05-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2021-33575/"}