# CVE-2021-33575: Remote code execution in ruby-jss


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-vmfh-c547-v45h

## What is CVE-2021-33575?

CVE-2021-33575 is a critical vulnerability in n/a, published on 25 May 2021. 

### Official description

The Pixar ruby-jss gem before 1.6.0 allows remote attackers to execute arbitrary code because of the Plist gem's documented behavior of using Marshal.load during XML document processing.

## Which versions are affected by CVE-2021-33575?

2 open source packages ship an affected version, including ruby-jss. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby-jss` | RubyGems | All versions | 1.6.0 |
| `ruby-jss` | RubyGems | All versions | 1.6.0 |

Products: Pixar Ruby-Jss.

## How do I fix CVE-2021-33575?

Upgrade ruby-jss to 1.6.0 or later.

## Is CVE-2021-33575 being exploited?

There is no known exploitation of CVE-2021-33575 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33575 and fix it if it is affected.

What it is: CVE-2021-33575 is a critical vulnerability in n/a, published on 25 May 2021. 
Exploitation: There is no known exploitation of CVE-2021-33575 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby-jss (RubyGems): affected all versions; fixed in 1.6.0
- ruby-jss (RubyGems): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33575/ (Markdown: https://insights.sbomify.com/CVE-2021-33575/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33575
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33575
- OSV: https://osv.dev/vulnerability/CVE-2021-33575

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33575/
Summaries are generated and may contain mistakes; the official description above is the record.
