# CVE-2021-33582: Denial of service in n/a

> Remote attackers can cause a denial of service in Cyrus IMAP by triggering slow hash-table interactions, requiring an upgrade to fixed versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2021
- **Updated:** 3 Aug 2024
- **Also known as:** CLSA-2022-1654106950, CLSA-2022-1654107183, CLSA-2022-1654174467, CLSA-2023-1688678110, CLSA-2026-1777279920, CLSA-2026-1777280127, CLSA-2026-1790640190, DEBIAN-CVE-2021-33582, GHSA-prxx-4m38-9m83, MGASA-2022-0247, RHSA-2021:3492, RHSA-2021:3493, RHSA-2021:3546, RLSA-2021:3492, UBUNTU-CVE-2021-33582, openSUSE-SU-2024:11901-1

## What is CVE-2021-33582?

CVE-2021-33582 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cyrus IMAP before 3.4.2 allows remote attackers to cause a denial of service (multiple-minute daemon hang) via input that is mishandled during hash-table interaction. Because there are many insertions into a single bucket, strcmp becomes slow. This is fixed in 3.4.2, 3.2.8, and 3.0.16.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2021-33582?

It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cyrus-imapd` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.0.7-20.el8_4.1 |
| `cyrus-imapd-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.0.7-20.el8_4.1 |
| `cyrus-imapd-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.0.7-20.el8_4.1 |
| `cyrus-imapd-utils` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.0.7-20.el8_4.1 |
| `cyrus-imapd-utils-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.0.7-20.el8_4.1 |
| `cyrus-imapd-vzic` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.0.7-20.el8_4.1 |
| `cyrus-imapd-vzic-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:3.0.7-20.el8_4.1 |
| `cyrus-imapd` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:3.0.7-16.el8_1.1 |
| `cyrus-imapd-debuginfo` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:3.0.7-16.el8_1.1 |
| `cyrus-imapd-debugsource` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:3.0.7-16.el8_1.1 |
| `cyrus-imapd-utils` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:3.0.7-16.el8_1.1 |
| `cyrus-imapd-utils-debuginfo` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:3.0.7-16.el8_1.1 |
| `cyrus-imapd-vzic` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:3.0.7-16.el8_1.1 |
| `cyrus-imapd-vzic-debuginfo` | Red Hat:rhel_eus:8.1::appstream | All versions | 0:3.0.7-16.el8_1.1 |
| `cyrus-imapd` | Red Hat:rhel_eus:8.2::appstream | All versions | 0:3.0.7-16.el8_2.1 |
| `cyrus-imapd-debuginfo` | Red Hat:rhel_eus:8.2::appstream | All versions | 0:3.0.7-16.el8_2.1 |
| `cyrus-imapd-debugsource` | Red Hat:rhel_eus:8.2::appstream | All versions | 0:3.0.7-16.el8_2.1 |
| `cyrus-imapd-utils` | Red Hat:rhel_eus:8.2::appstream | All versions | 0:3.0.7-16.el8_2.1 |
| `cyrus-imapd-utils-debuginfo` | Red Hat:rhel_eus:8.2::appstream | All versions | 0:3.0.7-16.el8_2.1 |
| `cyrus-imapd-vzic` | Red Hat:rhel_eus:8.2::appstream | All versions | 0:3.0.7-16.el8_2.1 |
| `cyrus-imapd-vzic-debuginfo` | Red Hat:rhel_eus:8.2::appstream | All versions | 0:3.0.7-16.el8_2.1 |
| `cyrus-imapd` | Rocky Linux:8 | All versions | 0:3.0.7-20.el8_4.1 |
| `cyrus-imapd` | openSUSE:Tumbleweed | All versions | 2.4.22-2.1 |

Products: Cyrus Imap, Debian Debian Linux, Fedoraproject Fedora.

## How do I fix CVE-2021-33582?

Upgrade to a fixed version.

## Is CVE-2021-33582 being exploited?

There is no known exploitation of CVE-2021-33582 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2019-18928](https://insights.sbomify.com/CVE-2019-18928/): Auth bypass in n/a (critical 9.8)
- [CVE-2017-14230](https://insights.sbomify.com/CVE-2017-14230/): Information disclosure in n/a (critical 9.1)
- [CVE-2015-8076](https://insights.sbomify.com/CVE-2015-8076/): Information disclosure in n/a (high 7.5)
- [CVE-2015-8077](https://insights.sbomify.com/CVE-2015-8077/): Integer overflow in n/a (high 7.5)
- [CVE-2015-8078](https://insights.sbomify.com/CVE-2015-8078/): Integer overflow in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33582 and fix it if it is affected.

What it is: CVE-2021-33582 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-33582 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33582/ (Markdown: https://insights.sbomify.com/CVE-2021-33582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33582
- OSV: https://osv.dev/vulnerability/CVE-2021-33582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33582/
Summaries are generated and may contain mistakes; the official description above is the record.
