# CVE-2021-33587: Denial of service in css-what

> An attacker can cause a denial of service by providing input that triggers quadratic time complexity in the CSS attribute parser.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** CLSA-2026-1790414394, DEBIAN-CVE-2021-33587, GHSA-q8pj-2vqx-8ggc, ROOT-APP-NPM-CVE-2021-33587, UBUNTU-CVE-2021-33587

## What is CVE-2021-33587?

CVE-2021-33587 is a high-severity denial of service vulnerability in Netapp E-Series Performance Analyzer, published on 28 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The css-what package 4.0.0 through 5.0.0 for Node.js does not ensure that attribute parsing has Linear Time Complexity relative to the size of the input.

## Which versions are affected by CVE-2021-33587?

2 open source packages ship an affected version, including css-what. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `css-what` | npm | From 4.0.0 | 5.0.1 |
| `css-what` | npm | From 4.0.0 | 5.0.1 |

Products: Css-What Project Css-What, Netapp E-Series Performance Analyzer.

## How do I fix CVE-2021-33587?

Upgrade css-what to 5.0.1 or later.

## Is CVE-2021-33587 being exploited?

There is no known exploitation of CVE-2021-33587 in the wild and no public exploit code.

## Other vulnerabilities in Netapp E-Series Performance Analyzer

- [CVE-2022-21222](https://insights.sbomify.com/CVE-2022-21222/): Regular Expression Denial of Service (ReDoS) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33587 and fix it if it is affected.

What it is: CVE-2021-33587 is a high-severity denial of service vulnerability in Netapp E-Series Performance Analyzer, published on 28 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-33587 in the wild and no public exploit code.

Affected packages and fixed versions:
- css-what (npm): affected from 4.0.0; fixed in 5.0.1
- css-what (npm): affected from 4.0.0; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33587/ (Markdown: https://insights.sbomify.com/CVE-2021-33587/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33587
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33587
- OSV: https://osv.dev/vulnerability/CVE-2021-33587

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33587/
Summaries are generated and may contain mistakes; the official description above is the record.
