CVE-2021-33604 Reflected cross-site scripting in development mode handler in Vaadin 14, 15-19
Attackers can execute arbitrary JavaScript via crafted URLs in Vaadin development mode, requiring the feature to be enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-33604?
CVE-2021-33604 is a low-severity cross-site scripting vulnerability in Vaadin, published on 24 Jun 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
URL encoding error in development mode handler in com.vaadin:flow-server versions 2.0.0 through 2.6.1 (Vaadin 14.0.0 through 14.6.1), 3.0.0 through 6.0.9 (Vaadin 15.0.0 through 19.0.8) allows local user to execute arbitrary JavaScript code by opening crafted URL in browser.
Weakness: CWE-172
Which versions are affected by CVE-2021-33604?
4 open source packages ship an affected version, including com.vaadin:vaadin-bom. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
com.vaadin:vaadin-bom Maven | From 14.0.0 | 14.6.2 |
com.vaadin:vaadin-bom Maven | From 14.0.0 | 14.6.2 |
com.vaadin:vaadin-bom Maven | From 15.0.0 | 19.0.9 |
com.vaadin:vaadin-bom Maven | From 15.0.0 | 19.0.9 |
Products include Vaadin Flow-Server, Vaadin Vaadin.
How do I fix CVE-2021-33604?
Upgrade com.vaadin:vaadin-bom to a fixed version for your release line: 14.6.2 or 19.0.9.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-33604 being exploited?
There is no known exploitation of CVE-2021-33604 in the wild and no public exploit code.
Sources
Also known as GHSA-c99r-67x4-whj6.