CVE-2021-33605 Unauthorized property update in CheckboxGroup component in Vaadin 12-14 and 15-20
Attackers can modify disabled checkbox values in Vaadin CheckboxGroup components, bypassing intended UI restrictions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-33605?
CVE-2021-33605 is a medium-severity vulnerability in Vaadin, published on 25 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper check in CheckboxGroup in com.vaadin:vaadin-checkbox-flow versions 1.2.0 prior to 2.0.0 (Vaadin 12.0.0 prior to 14.0.0), 2.0.0 prior to 3.0.0 (Vaadin 14.0.0 prior to 14.5.0), 3.0.0 through 4.0.1 (Vaadin 15.0.0 through 17.0.11), 14.5.0 through 14.6.7 (Vaadin 14.5.0 through 14.6.7), and 18.0.0 through 20.0.5 (Vaadin 18.0.0 through 20.0.5) allows attackers to modify the value of a disabled Checkbox inside enabled CheckboxGroup component via unspecified vectors.
Weakness: CWE-754
Which versions are affected by CVE-2021-33605?
4 open source packages ship an affected version, including com.vaadin:vaadin-checkbox-flow. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.vaadin:vaadin-checkbox-flow Maven | From 12.0.0 | 14.6.8 |
com.vaadin:vaadin-checkbox-flow Maven | From 12.0.0 | 14.6.8 |
com.vaadin:vaadin-checkbox-flow Maven | From 15.0.0 | 20.0.6 |
com.vaadin:vaadin-checkbox-flow Maven | From 15.0.0 | 20.0.6 |
Products include Vaadin Vaadin-Checkbox-Flow.
How do I fix CVE-2021-33605?
Upgrade com.vaadin:vaadin-checkbox-flow to a fixed version for your release line: 14.6.8 or 20.0.6.
Is CVE-2021-33605 being exploited?
There is no known exploitation of CVE-2021-33605 in the wild and no public exploit code.
Sources
Also known as GHSA-qcc4-3rxf-gf4m.