# CVE-2021-33611: Reflected cross-site scripting in vaadin-menu-bar webjar resources in Vaadin 14

> Remote attackers can execute malicious JavaScript in browsers via crafted URLs due to missing output sanitization in Vaadin menu bar webjar resources.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Nov 2021
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-93c4-vf86-3rj7

## What is CVE-2021-33611?

CVE-2021-33611 is a medium-severity cross-site scripting vulnerability in Vaadin, published on 2 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Missing output sanitization in test sources in org.webjars.bowergithub.vaadin:vaadin-menu-bar versions 1.0.0 through 1.2.0 (Vaadin 14.0.0 through 14.4.4) allows remote attackers to execute malicious JavaScript in browser by opening crafted URL

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-33611?

4 open source packages ship an affected version, including com.vaadin:vaadin-bom and org.webjars.bowergithub.vaadin:vaadin-menu-bar. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:vaadin-bom` | Maven | From 14.0.0 | 14.4.5 |
| `com.vaadin:vaadin-bom` | Maven | From 14.0.0 | 14.4.5 |
| `org.webjars.bowergithub.vaadin:vaadin-menu-bar` | Maven | From 1.0.0 | 1.2.1 |
| `org.webjars.bowergithub.vaadin:vaadin-menu-bar` | Maven | From 1.0.0 | 1.2.1 |

Products: Vaadin Vaadin, Vaadin Vaadin-Menu-Bar.

## How do I fix CVE-2021-33611?

Upgrade com.vaadin:vaadin-bom to 14.4.5 or later.

## Is CVE-2021-33611 being exploited?

There is no known exploitation of CVE-2021-33611 in the wild and no public exploit code.

## Other vulnerabilities in Vaadin

- [CVE-2021-31409](https://insights.sbomify.com/CVE-2021-31409/): Server session is not invalidated when logout() helper method of Authentication module is used in Vaadin 18-19 (high 7.5)
- [CVE-2020-36320](https://insights.sbomify.com/CVE-2020-36320/): Regular expression Denial of Service (ReDoS) in EmailValidator class in Vaadin 7 (high 7.5)
- [CVE-2023-25499](https://insights.sbomify.com/CVE-2023-25499/): Possible information disclosure in non visible components (medium 5.7)
- [CVE-2022-29567](https://insights.sbomify.com/CVE-2022-29567/): Possible information disclosure inside TreeGrid component with default data provider (medium 5.7)
- [CVE-2019-25028](https://insights.sbomify.com/CVE-2019-25028/): Stored cross-site scripting in Grid component in Vaadin 7 and 8 (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33611 and fix it if it is affected.

What it is: CVE-2021-33611 is a medium-severity cross-site scripting vulnerability in Vaadin, published on 2 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-33611 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:vaadin-bom (Maven): affected from 14.0.0; fixed in 14.4.5
- com.vaadin:vaadin-bom (Maven): affected from 14.0.0; fixed in 14.4.5
- org.webjars.bowergithub.vaadin:vaadin-menu-bar (Maven): affected from 1.0.0; fixed in 1.2.1
- org.webjars.bowergithub.vaadin:vaadin-menu-bar (Maven): affected from 1.0.0; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33611/ (Markdown: https://insights.sbomify.com/CVE-2021-33611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33611
- OSV: https://osv.dev/vulnerability/CVE-2021-33611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33611/
Summaries are generated and may contain mistakes; the official description above is the record.
