{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-33620 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-33620 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 28 May 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-33620 and fix it if it is affected.\n\nWhat it is: CVE-2021-33620 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 28 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-33620 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-33620/ (Markdown: https://insights.sbomify.com/CVE-2021-33620/index.md)","id":"CVE-2021-33620","markdown":"https://insights.sbomify.com/CVE-2021-33620/index.md","name":"CVE-2021-33620","record":{"aliases":["ALPINE-CVE-2021-33620","DEBIAN-CVE-2021-33620","GHSA-56g5-gjqr-cc85","GHSA-572g-rvwr-6c7f","UBUNTU-CVE-2021-33620","openSUSE-SU-2024:11929-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Squid proxy server","requires_auth":"low_privilege","summary":"Remote servers can cause a denial of service in Squid proxy via crafted HTTP responses, affecting availability for all clients.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"squid","vendor":"squid-cache"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AC:L/AV:N/A:H/C:N/I:N/PR:L/S:U/UI:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Squid before 4.15 and 5.x before 5.0.6 allows remote servers to cause a denial of service (affecting availability to all clients) via an HTTP response. The issue trigger is a header that can be expected to exist in HTTP traffic without any malicious intent by the server.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2021-33620","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","squid-cache:squid"],"type":"denial_of_service","year":"2021"},"n_packages":1,"n_references":8,"next":{"headline":"HTTP response splitting in CGI","id":"CVE-2021-33621"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.4.1-2.1"],"introduced":["0"],"last_affected":[],"package":"squid","purl":"pkg:rpm/opensuse/squid\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11929-1"}],"prev":{"headline":"Dolibarr ERP and CRM contain XSS Vulnerability","id":"CVE-2021-33618"},"products":["n/a"],"published":"2021-05-28","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Remote servers can cause a denial of service in Squid proxy via crafted HTTP responses, affecting availability for all clients.","url":"https://insights.sbomify.com/CVE-2021-33620/"}