CVE-2021-33621 HTTP response splitting in CGI

High 8.8 Published Updated

Attackers can perform HTTP response splitting in Ruby applications using the CGI gem, potentially modifying responses or bypassing security controls.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-33621?

CVE-2021-33621 is a high-severity vulnerability in Fedoraproject Fedora, published on 18 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.

Weakness: CWE-74

Which versions are affected by CVE-2021-33621?

8 open source packages ship an affected version, including cgi, ruby and ruby-min. It affects 3 products.

PackageAffectedFixed in
cgi RubyGemsAll versions0.1.0.2
cgi RubyGemsAll versions0.1.0.2
cgi RubyGemsFrom 0.2.00.2.2
cgi RubyGemsFrom 0.2.00.2.2
cgi RubyGemsFrom 0.3.00.3.5
cgi RubyGemsFrom 0.3.00.3.5
2 more packages
ruby BitnamiFrom 2.7.02.7.7, 3.0.5, 3.1.3
ruby-min BitnamiFrom 2.7.02.7.7, 3.0.5, 3.1.3
Linux distribution packages (30)
ruby Red Hat:rhel_eus:9.2::appstreamAll versions0:3.0.4-161.el9_2.1
ruby-debuginfo Red Hat:rhel_eus:9.2::appstreamAll versions0:3.0.4-161.el9_2.1
ruby-debugsource Red Hat:rhel_eus:9.2::appstreamAll versions0:3.0.4-161.el9_2.1
ruby-default-gems Red Hat:rhel_eus:9.2::appstreamAll versions0:3.0.4-161.el9_2.1
ruby-devel Red Hat:rhel_eus:9.2::appstreamAll versions0:3.0.4-161.el9_2.1
ruby-libs Red Hat:rhel_eus:9.2::appstreamAll versions0:3.0.4-161.el9_2.1
ruby-libs-debuginfo Red Hat:rhel_eus:9.2::appstreamAll versions0:3.0.4-161.el9_2.1
rubygem-bigdecimal Red Hat:rhel_eus:9.2::appstreamAll versions0:3.0.0-161.el9_2.1
rubygem-bigdecimal-debuginfo Red Hat:rhel_eus:9.2::appstreamAll versions0:3.0.0-161.el9_2.1
rubygem-bundler Red Hat:rhel_eus:9.2::appstreamAll versions0:2.2.33-161.el9_2.1
rubygem-io-console Red Hat:rhel_eus:9.2::appstreamAll versions0:0.5.7-161.el9_2.1
rubygem-io-console-debuginfo Red Hat:rhel_eus:9.2::appstreamAll versions0:0.5.7-161.el9_2.1
rubygem-irb Red Hat:rhel_eus:9.2::appstreamAll versions0:1.3.5-161.el9_2.1
rubygem-json Red Hat:rhel_eus:9.2::appstreamAll versions0:2.5.1-161.el9_2.1
rubygem-json-debuginfo Red Hat:rhel_eus:9.2::appstreamAll versions0:2.5.1-161.el9_2.1
rubygem-minitest Red Hat:rhel_eus:9.2::appstreamAll versions0:5.14.2-161.el9_2.1
rubygem-power_assert Red Hat:rhel_eus:9.2::appstreamAll versions0:1.2.0-161.el9_2.1
rubygem-psych Red Hat:rhel_eus:9.2::appstreamAll versions0:3.3.2-161.el9_2.1
rubygem-psych-debuginfo Red Hat:rhel_eus:9.2::appstreamAll versions0:3.3.2-161.el9_2.1
rubygem-rake Red Hat:rhel_eus:9.2::appstreamAll versions0:13.0.3-161.el9_2.1
rubygem-rbs Red Hat:rhel_eus:9.2::appstreamAll versions0:1.4.0-161.el9_2.1
rubygem-rdoc Red Hat:rhel_eus:9.2::appstreamAll versions0:6.3.3-161.el9_2.1
rubygem-rexml Red Hat:rhel_eus:9.2::appstreamAll versions0:3.2.5-161.el9_2.1
rubygem-rss Red Hat:rhel_eus:9.2::appstreamAll versions0:0.2.9-161.el9_2.1
rubygem-test-unit Red Hat:rhel_eus:9.2::appstreamAll versions0:3.3.7-161.el9_2.1
rubygem-typeprof Red Hat:rhel_eus:9.2::appstreamAll versions0:0.15.2-161.el9_2.1
rubygems Red Hat:rhel_eus:9.2::appstreamAll versions0:3.2.33-161.el9_2.1
rubygems-devel Red Hat:rhel_eus:9.2::appstreamAll versions0:3.2.33-161.el9_2.1
ruby-doc Red Hat:rhel_eus:9.2::crbAll versions0:3.0.4-161.el9_2.1
ruby3.1 openSUSE:TumbleweedAll versions3.1.3-1.1

Products include Fedoraproject Fedora, Ruby-Lang Cgi, Ruby-Lang Ruby.

How do I fix CVE-2021-33621?

Upgrade cgi to a fixed version for your release line: 0.1.0.2, 0.2.2 or 0.3.5.

Is CVE-2021-33621 being exploited?

There is no known exploitation of CVE-2021-33621 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as ALPINE-CVE-2021-33621, BIT-ruby-2021-33621, BIT-ruby-min-2021-33621, CLEANSTART-2026-JL84667, DEBIAN-CVE-2021-33621, GHSA-vc47-6rqg-c7f5 and 9 more.

Is CVE-2021-33621 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free