# CVE-2021-33621: HTTP response splitting in CGI

> Attackers can perform HTTP response splitting in Ruby applications using the CGI gem, potentially modifying responses or bypassing security controls.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2022
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2021-33621, BIT-ruby-2021-33621, BIT-ruby-min-2021-33621, CLEANSTART-2026-JL84667, DEBIAN-CVE-2021-33621, GHSA-vc47-6rqg-c7f5, JLSEC-2026-1286, MGASA-2022-0454, OESA-2023-1003, RHSA-2024:4542, UBUNTU-CVE-2021-33621, USN-5806-1, USN-5806-2, USN-5806-3, openSUSE-SU-2024:12539-1

## What is CVE-2021-33621?

CVE-2021-33621 is a high-severity vulnerability in Fedoraproject Fedora, published on 18 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2021-33621?

8 open source packages ship an affected version, including cgi, ruby and ruby-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cgi` | RubyGems | All versions | 0.1.0.2 |
| `cgi` | RubyGems | All versions | 0.1.0.2 |
| `cgi` | RubyGems | From 0.2.0 | 0.2.2 |
| `cgi` | RubyGems | From 0.2.0 | 0.2.2 |
| `cgi` | RubyGems | From 0.3.0 | 0.3.5 |
| `cgi` | RubyGems | From 0.3.0 | 0.3.5 |
| `ruby` | Bitnami | From 2.7.0 | 2.7.7, 3.0.5, 3.1.3 |
| `ruby-min` | Bitnami | From 2.7.0 | 2.7.7, 3.0.5, 3.1.3 |
| `ruby` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.0.4-161.el9_2.1 |
| `ruby-debuginfo` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.0.4-161.el9_2.1 |
| `ruby-debugsource` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.0.4-161.el9_2.1 |
| `ruby-default-gems` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.0.4-161.el9_2.1 |
| `ruby-devel` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.0.4-161.el9_2.1 |
| `ruby-libs` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.0.4-161.el9_2.1 |
| `ruby-libs-debuginfo` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.0.4-161.el9_2.1 |
| `rubygem-bigdecimal` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.0.0-161.el9_2.1 |
| `rubygem-bigdecimal-debuginfo` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.0.0-161.el9_2.1 |
| `rubygem-bundler` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:2.2.33-161.el9_2.1 |
| `rubygem-io-console` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:0.5.7-161.el9_2.1 |
| `rubygem-io-console-debuginfo` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:0.5.7-161.el9_2.1 |
| `rubygem-irb` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.3.5-161.el9_2.1 |
| `rubygem-json` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:2.5.1-161.el9_2.1 |
| `rubygem-json-debuginfo` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:2.5.1-161.el9_2.1 |
| `rubygem-minitest` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:5.14.2-161.el9_2.1 |
| `rubygem-power_assert` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.2.0-161.el9_2.1 |
| `rubygem-psych` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.3.2-161.el9_2.1 |
| `rubygem-psych-debuginfo` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.3.2-161.el9_2.1 |
| `rubygem-rake` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:13.0.3-161.el9_2.1 |
| `rubygem-rbs` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:1.4.0-161.el9_2.1 |
| `rubygem-rdoc` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:6.3.3-161.el9_2.1 |
| `rubygem-rexml` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.2.5-161.el9_2.1 |
| `rubygem-rss` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:0.2.9-161.el9_2.1 |
| `rubygem-test-unit` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.3.7-161.el9_2.1 |
| `rubygem-typeprof` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:0.15.2-161.el9_2.1 |
| `rubygems` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.2.33-161.el9_2.1 |
| `rubygems-devel` | Red Hat:rhel_eus:9.2::appstream | All versions | 0:3.2.33-161.el9_2.1 |
| `ruby-doc` | Red Hat:rhel_eus:9.2::crb | All versions | 0:3.0.4-161.el9_2.1 |
| `ruby3.1` | openSUSE:Tumbleweed | All versions | 3.1.3-1.1 |

Products: Fedoraproject Fedora, Ruby-Lang Cgi, Ruby-Lang Ruby.

## How do I fix CVE-2021-33621?

Upgrade cgi to a fixed version for your release line: 0.1.0.2, 0.2.2 or 0.3.5.

## Is CVE-2021-33621 being exploited?

There is no known exploitation of CVE-2021-33621 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33621 and fix it if it is affected.

What it is: CVE-2021-33621 is a high-severity vulnerability in Fedoraproject Fedora, published on 18 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-33621 in the wild and no public exploit code.

Affected packages and fixed versions:
- cgi (RubyGems): affected all versions; fixed in 0.1.0.2
- cgi (RubyGems): affected all versions; fixed in 0.1.0.2
- cgi (RubyGems): affected from 0.2.0; fixed in 0.2.2
- cgi (RubyGems): affected from 0.2.0; fixed in 0.2.2
- cgi (RubyGems): affected from 0.3.0; fixed in 0.3.5
- cgi (RubyGems): affected from 0.3.0; fixed in 0.3.5
- ruby (Bitnami): affected from 2.7.0; fixed in 2.7.7, 3.0.5, 3.1.3
- ruby-min (Bitnami): affected from 2.7.0; fixed in 2.7.7, 3.0.5, 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33621/ (Markdown: https://insights.sbomify.com/CVE-2021-33621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33621
- OSV: https://osv.dev/vulnerability/CVE-2021-33621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33621/
Summaries are generated and may contain mistakes; the official description above is the record.
