{"answers":{"affected":"2 open source packages ship an affected version, including ansi_up. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-3377 exists.","fix":"Upgrade ansi_up to 5.0.0 or later.","what":"CVE-2021-3377 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-3377 and fix it if it is affected.\n\nWhat it is: CVE-2021-3377 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-3377 exists.\n\nAffected packages and fixed versions:\n- ansi_up (npm): affected all versions; fixed in 5.0.0\n- ansi_up (npm): affected all versions; fixed in 5.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3377/ (Markdown: https://insights.sbomify.com/CVE-2021-3377/index.md)","id":"CVE-2021-3377","markdown":"https://insights.sbomify.com/CVE-2021-3377/index.md","name":"CVE-2021-3377","record":{"aliases":["DEBIAN-CVE-2021-3377","GHSA-2v5f-23xc-v9qr","UBUNTU-CVE-2021-3377"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"npm ANSI converter","requires_auth":"none","summary":"An attacker can inject malicious scripts via ANSI escape codes in the ansi_up library, leading to cross-site scripting attacks.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ansi_up","vendor":"ansi_up_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2021/CVE-2021-3377.yaml","stars":null,"title":"npm ansi_up v4 - Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"ansi_up cross-site scripting vulnerability","id":"CVE-2021-3377","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"File upload in n/a","id":"CVE-2021-3378"},"packages":[{"ecosystem":"npm","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"ansi_up","purl":null,"source":"GHSA-2v5f-23xc-v9qr"},{"ecosystem":"npm","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"ansi_up","purl":"pkg:npm/ansi_up","source":"GHSA-2v5f-23xc-v9qr"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2021-3376"},"products":["n/a"],"published":"2021-03-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-11-03","vendors":["n/a"]},"summary":"An attacker can inject malicious scripts via ANSI escape codes in the ansi_up library, leading to cross-site scripting attacks.","url":"https://insights.sbomify.com/CVE-2021-3377/"}