# CVE-2021-3377: ansi_up cross-site scripting vulnerability

> An attacker can inject malicious scripts via ANSI escape codes in the ansi_up library, leading to cross-site scripting attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Mar 2021
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2021-3377, GHSA-2v5f-23xc-v9qr, UBUNTU-CVE-2021-3377

## What is CVE-2021-3377?

CVE-2021-3377 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-3377?

2 open source packages ship an affected version, including ansi_up. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansi_up` | npm | All versions | 5.0.0 |
| `ansi_up` | npm | All versions | 5.0.0 |

Products: Ansi Up Project Ansi Up.

## How do I fix CVE-2021-3377?

Upgrade ansi_up to 5.0.0 or later.

## Is CVE-2021-3377 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-3377 exists.

Public exploit code:

- npm ansi_up v4 - Cross-Site Scripting (nuclei): http/cves/2021/CVE-2021-3377.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3377 and fix it if it is affected.

What it is: CVE-2021-3377 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-3377 exists.

Affected packages and fixed versions:
- ansi_up (npm): affected all versions; fixed in 5.0.0
- ansi_up (npm): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3377/ (Markdown: https://insights.sbomify.com/CVE-2021-3377/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3377
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3377
- OSV: https://osv.dev/vulnerability/CVE-2021-3377

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3377/
Summaries are generated and may contain mistakes; the official description above is the record.
