# CVE-2021-33816: Dolibarr remote PHP code execution

> Remote attackers can execute arbitrary PHP code in Dolibarr's website builder due to incomplete command blocking, requiring immediate patching.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-dolibarr-2021-33816, GHSA-vxr9-p2xw-m8cf, UBUNTU-CVE-2021-33816

## What is CVE-2021-33816?

CVE-2021-33816 is a critical code injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 10 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The website builder module in Dolibarr 13.0.2 allows remote PHP code execution because of an incomplete protection mechanism in which system, exec, and shell_exec are blocked but backticks are not blocked.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2021-33816?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | From 13.0.2 | 14.0.0 |
| `dolibarr/dolibarr` | Packagist | From 13.0.2 | 14.0.0 |
| `dolibarr` | Bitnami | From 13.0.2 to 13.0.2 | None |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2021-33816?

Upgrade dolibarr/dolibarr to 14.0.0 or later.

## Is CVE-2021-33816 being exploited?

There is no known exploitation of CVE-2021-33816 in the wild and no public exploit code.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)
- [CVE-2013-2093](https://insights.sbomify.com/CVE-2013-2093/): Command injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-33816 and fix it if it is affected.

What it is: CVE-2021-33816 is a critical code injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 10 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-33816 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected from 13.0.2; fixed in 14.0.0
- dolibarr/dolibarr (Packagist): affected from 13.0.2; fixed in 14.0.0
- dolibarr (Bitnami): affected from 13.0.2 up to 13.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-33816/ (Markdown: https://insights.sbomify.com/CVE-2021-33816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-33816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-33816
- OSV: https://osv.dev/vulnerability/CVE-2021-33816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-33816/
Summaries are generated and may contain mistakes; the official description above is the record.
