CVE-2021-33829 ckeditor4 vulnerable to cross-site scripting
Remote attackers can inject executable JavaScript via crafted comments in CKEditor's HTML Data Processor, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-33829?
CVE-2021-33829 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 9 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --!> is mishandled.
Weakness: CWE-79
Which versions are affected by CVE-2021-33829?
20 open source packages ship an affected version, including drupal/core, drupal and drupal/drupal. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 7.0.0 | 7.80 |
drupal/core Packagist | From 7.0.0 | 7.80 |
drupal/core Packagist | From 8.0.0 | 8.9.16, 9.0.14, 9.1.9 |
drupal/core Packagist | From 8.0.0 | 8.9.16 |
drupal/core Packagist | From 8.0.0 | 8.9.16 |
drupal/core Packagist | From 9.0.0 | 9.0.14 |
14 more packages
drupal/core Packagist | From 9.0.0 | 9.0.14 |
drupal/core Packagist | From 9.1.0 | 9.1.9 |
drupal/core Packagist | From 9.1.0 | 9.1.9 |
drupal Bitnami | From 8.9.0 | 8.9.16, 9.0.14, 9.1.9 |
drupal/drupal Packagist | From 7.0.0 | 7.80 |
drupal/drupal Packagist | From 7.0.0 | 7.80 |
drupal/drupal Packagist | From 8.0.0 | 8.9.16 |
drupal/drupal Packagist | From 8.0.0 | 8.9.16 |
drupal/drupal Packagist | From 9.0.0 | 9.0.14 |
drupal/drupal Packagist | From 9.0.0 | 9.0.14 |
drupal/drupal Packagist | From 9.1.0 | 9.1.9 |
drupal/drupal Packagist | From 9.1.0 | 9.1.9 |
ckeditor4 npm | From 4.14.0 | 4.16.1 |
ckeditor4 npm | From 4.14.0 | 4.16.1 |
Products include Ckeditor Ckeditor, Debian Debian Linux, Drupal Drupal, Fedoraproject Fedora.
How do I fix CVE-2021-33829?
Upgrade drupal/core to a fixed version for your release line: 7.80, 8.9.16, 9.0.14 or 9.1.9.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-33829 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-33829 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in Debian Debian Linux
- CVE-2023-31541 File upload in n/a
- CVE-2021-41164 Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML
- CVE-2021-41165 HTML comments vulnerability allowing to execute JavaScript code
- CVE-2021-32808 Cross-site scripting in ckeditor via abuse of undo functionality
- CVE-2011-4972 Missing authorization in CKEditor Drupal module
Sources
Also known as BIT-drupal-2021-33829, DEBIAN-CVE-2021-33829, DRUPAL-CORE-2021-003, GHSA-rgx6-rjj4-c388, UBUNTU-CVE-2021-33829.